Project

General

Profile

Bug #19642

Puppet classes are not available for inclusion in host groups until imported from the filesystem

Added by Josh Pavel almost 2 years ago. Updated 11 months ago.

Status:
Duplicate
Priority:
Normal
Category:
Puppet
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

I wasn't sure if this should be katello-integration or puppet integration.

When we add puppet modules in Katello and promote the content views, we are no longer able to view/add/include the new classes in hostgroups.

As a workaround, I need to go to Configure -> Puppet Classes and "Import" from the filesystem. After that, I am able to add the classes to the hostgroup.


Related issues

Is duplicate of Katello - Bug #19338: CV publishing with puppet module does not add puppet classClosed2017-04-20

History

#1 Updated by Ohad Levy almost 2 years ago

  • Project changed from Foreman to Katello
  • Category deleted (Puppet integration)

moving to katello, as it can be afaiu is triggering the import action when content is published.

#2 Updated by Justin Sherrill almost 2 years ago

  • Category set to Puppet
  • Status changed from New to Duplicate
  • Assignee set to Brad Buckingham
  • Legacy Backlogs Release (now unused) set to 211

#3 Updated by Justin Sherrill almost 2 years ago

  • Is duplicate of Bug #19338: CV publishing with puppet module does not add puppet class added

Also available in: Atom PDF