Project

General

Profile

Feature #19666

Return record type for DHCP recorts

Added by Lukas Zapletal over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
DHCP
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

We do not show if a record is type of lease or reservation. This can be useful information. I am filing this for #19634 bug but I might end up not use this information, still I would like Smart Proxy to report this.

It looks like we have also a regression when less information is returned, I can include this in the patch as well.

Smart-Proxy 1.15:

[lzap@lzapx smart-proxy]$ curl-proxy /dhcp/192.168.122.0/192.168.122.6
{
    "hostname": "lease-525400130513",
    "ip": "192.168.122.6",
    "mac": "52:54:00:13:05:13" 
}

Smart-Proxy 1.14:

[lzap@lzapx smart-proxy]$ curl-proxy /dhcp/192.168.122.0/192.168.122.6
{
    "starts": "2017-05-24 12:52:59 UTC",
    "ends": "2017-05-24 13:02:59 UTC",
    "state": "active",
    "next_state": "free",
    "mac": "52:54:00:13:05:13",
    "subnet": "192.168.122.0/255.255.255.0",
    "ip": "192.168.122.6" 
}

Related issues

Related to Foreman - Bug #19634: DHCP lease removal leads to errorClosed2017-05-23
Related to Foreman - Refactor #19706: Don't treat DHCP leases as conflictsClosed2017-05-30

Associated revisions

Revision 52a4727f (diff)
Added by Lukas Zapletal over 3 years ago

Fixes #19666 - add DHCP record type field

History

#1 Updated by Lukas Zapletal over 3 years ago

  • Related to Bug #19634: DHCP lease removal leads to error added

#2 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Lukas Zapletal
  • Pull request https://github.com/theforeman/smart-proxy/pull/532 added

#3 Updated by Dmitri Dolguikh over 3 years ago

It looks like we have also a regression when less information is returned, I can include this in the patch as well

This is when a deprecated call is used. Newly added end-points return complete records.

#4 Updated by Anonymous over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Lukas Zapletal over 3 years ago

  • Legacy Backlogs Release (now unused) set to 248

Proposing this to 1.15, it only adds new field, low risk. Needed for lease detection in core (see the associated ticket).

#6 Updated by Dominic Cleal over 3 years ago

Also available in: Atom PDF