Project

General

Profile

Bug #19703

Cannot enter text into Publish new version Description text field

Added by Lachlan Simpson about 1 year ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Content Views
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When publishing a new version of a Content View, the Description text field doesn't stay in focus.

(on centos 7.3, just updated from foreman 1.14 and katello 3.3 to foreman 1.15/katello 3.4)

History

#1 Updated by Justin Sherrill about 1 year ago

  • Legacy Backlogs Release (now unused) changed from 211 to 228

#2 Updated by Justin Sherrill about 1 year ago

  • Legacy Backlogs Release (now unused) changed from 228 to 258

#3 Updated by Justin Sherrill about 1 year ago

  • Assignee set to Walden Raines
  • Target version set to 195

#4 Updated by Walden Raines about 1 year ago

  • Status changed from New to Need more information

I cannot reproduce this in either the 3.4.0 or in 3.4.1. Can you provide any more specifics?

#5 Updated by Justin Sherrill about 1 year ago

  • Legacy Backlogs Release (now unused) changed from 258 to 166

#6 Updated by Justin Sherrill about 1 year ago

  • Legacy Backlogs Release (now unused) changed from 166 to 267

#7 Updated by Lachlan Simpson about 1 year ago

Walden Raines wrote:

I cannot reproduce this in either the 3.4.0 or in 3.4.1. Can you provide any more specifics?

With the versions I noted, in two OSes (debian stretch, Windows 7) in two browsers (Chromium, Firefox; Chrome, Firefox) when I click publish in the GUI I am presented with a text box for description and two buttons, save and cancel.

Clicking in the description window didn't "stick" - focus would immediately jump out to the buttons.

#8 Updated by Walden Raines about 1 year ago

Lachlan Simpson wrote:

Walden Raines wrote:

I cannot reproduce this in either the 3.4.0 or in 3.4.1. Can you provide any more specifics?

With the versions I noted, in two OSes (debian stretch, Windows 7) in two browsers (Chromium, Firefox; Chrome, Firefox) when I click publish in the GUI I am presented with a text box for description and two buttons, save and cancel.

Clicking in the description window didn't "stick" - focus would immediately jump out to the buttons.

Hmm. Relevant packages for me:

tfm-rubygem-bastion-5.0.6-1.fm1_15.el7.noarch
katello-3.4.1-1.el7.noarch
foreman-1.15.1-1.el7.noarch

What about you? Just want to make sure we are using the same bits.

#9 Updated by Tony Coffman about 1 year ago

I have the same symptom on my Katello 3.4.0 instance using Chrome 59.0.3071.104 on Windows 10 1703.

When I click into the description box it gains focus (textbox outline changes from light grey to light blue) and as soon as you release the mouse button it loses focus (returns to light grey) and further keyboard input is ignored in the textbox.

My workaround is to click into the Description field and hold the right mouse button down while typing text into the Description box with the other hand.

tfm-rubygem-bastion-5.0.0-1.fm1_15.el7.noarch
katello-3.4.0-3.el7.noarch
foreman-1.15.0-1.el7.noarch

#10 Updated by Walden Raines about 1 year ago

  • Status changed from Need more information to Resolved

This appears to be fixed in 3.4.1. Are you sure you're running 3.4.1 and that the upgrade was successful (including bastion)?

I am marking this as resolved as we have tested multiple instances of 3.4.1 and have not been able to reproduce this.

#11 Updated by Lachlan Simpson about 1 year ago

Yes, it does appear fixed in 3.4.1

I found the same work around as Tony - we had the same versions of the software listed.

#12 Updated by Eric Helms about 1 year ago

  • Legacy Backlogs Release (now unused) changed from 267 to 258

Also available in: Atom PDF