Project

General

Profile

Bug #19723

installer fails if a line isn't utf-8 encoded

Added by Sean O'Keeffe almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

since ://github.com/theforeman/puppet-tftp/commit/b52230c23696737f3d9f206ed7fe460fb9c9b565 kafo doesn't work https

/usr/share/gems/gems/kafo-2.0.1/lib/kafo/progress_bar.rb:40:in `match': invalid byte sequence in UTF-8 (ArgumentError)
from /usr/share/gems/gems/kafo-2.0.1/lib/kafo/progress_bar.rb:40:in `update'
from /usr/share/gems/gems/kafo-2.0.1/lib/kafo/kafo_configure.rb:455:in `block (2 levels) in run_installation'
from /usr/share/gems/gems/kafo-2.0.1/lib/kafo/kafo_configure.rb:453:in `each'
from /usr/share/gems/gems/kafo-2.0.1/lib/kafo/kafo_configure.rb:453:in `block in run_installation'
from /usr/share/gems/gems/kafo-2.0.1/lib/kafo/kafo_configure.rb:451:in `spawn'
from /usr/share/gems/gems/kafo-2.0.1/lib/kafo/kafo_configure.rb:451:in `run_installation'
from /usr/share/gems/gems/kafo-2.0.1/lib/kafo/kafo_configure.rb:156:in `execute'
from /usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:68:in `run'
from /usr/share/gems/gems/kafo-2.0.1/lib/kafo/kafo_configure.rb:119:in `run'
from /usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:133:in `run'
from /usr/share/gems/gems/kafo-2.0.1/lib/kafo/kafo_configure.rb:163:in `run'

Associated revisions

Revision 7e818700 (diff)
Added by Sean O'Keeffe almost 3 years ago

Fixes #19723 - installer fails if a line isn't utf-8 encoded (#215)

History

#1 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/kafo/pull/215 added

#2 Updated by Anonymous almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF