Project

General

Profile

Bug #19738

WebUI LifeCycle Environment/Content View/Content Source don't always match actual values

Added by Josh Pavel about 1 year ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

This isn't true on every host, but it is true on a few hosts that connect to different smart-proxies. I'm not sure what is a common thread for the hosts.

"Edit" an affected host
What is displayed (In this example):
Lifecycle Environment: Library
Content View: NTG6 Elasticsearch
Content source: Azure NTG6 East US 2

Correct the values (In this example):
Lifecycle Environment: Test
  • At this point, content view refreshes to "NTG6 Elasticsearch", but if you do not re-select it explicitly, the change gets lost
    Content Source: MTL DMZ
Submit.
  • At this point, if you did not explicitly select a content view, the page gives an error that "Content View" can't be blank, even though it is populated.

The selected values appear to be correctly set if you view the host as a "Content Host", but if you go back into the host again, the original values are displayed.

Even when the "Host" displays different information from "Content Host", if you search for "lifecycle_environment = Library", this host does not display.


Related issues

Is duplicate of Katello - Bug #22357: "Content Source" not updated in the UIClosed2018-01-22

History

#1 Updated by Eric Helms about 1 year ago

  • Legacy Backlogs Release (now unused) set to 258

#2 Updated by Justin Sherrill about 1 year ago

  • Legacy Backlogs Release (now unused) changed from 258 to 267

#3 Updated by Justin Sherrill about 1 year ago

  • Assignee set to Partha Aji

#4 Updated by Justin Sherrill about 1 year ago

  • Legacy Backlogs Release (now unused) changed from 267 to 281

#5 Updated by Eric Helms about 1 year ago

  • Legacy Backlogs Release (now unused) changed from 281 to 286

#6 Updated by Eric Helms about 1 year ago

  • Legacy Backlogs Release (now unused) changed from 286 to 114

#7 Updated by Eric Helms about 1 year ago

  • Assignee changed from Partha Aji to Justin Sherrill
  • Legacy Backlogs Release (now unused) changed from 114 to 250

#8 Updated by Andrew Kofink 11 months ago

  • Assignee changed from Justin Sherrill to Partha Aji

#9 Updated by Justin Sherrill 9 months ago

  • Target version set to 232

#10 Updated by Brad Buckingham 9 months ago

  • Target version changed from 232 to 236

#11 Updated by Brad Buckingham 8 months ago

  • Target version changed from 236 to 240

#12 Updated by Brad Buckingham 8 months ago

  • Target version changed from 240 to 242

#13 Updated by Brad Buckingham 7 months ago

  • Target version changed from 242 to 245

#14 Updated by Andrew Kofink 6 months ago

  • Legacy Backlogs Release (now unused) deleted (250)

#15 Updated by John Mitsch 5 months ago

  • Is duplicate of Bug #22357: "Content Source" not updated in the UI added

#16 Updated by Andrew Kofink 5 months ago

  • Status changed from New to Closed

If anyone sees this issue, please feel free to reopen with relevant logs.

#17 Updated by Justin Sherrill 5 months ago

  • Legacy Backlogs Release (now unused) set to 166
  • Status changed from Closed to Rejected

Also available in: Atom PDF