Project

General

Profile

Bug #19756

pulp workers shut down and pulp errors on Katello 3.4

Added by John Mitsch about 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

katello-3.4.0-3.el7.noarch
pulp-server-2.12.2-1.el7.noarch

Got this when trying to enable a repo, restarting pulp services fixed it

2017-06-02 14:47:11 6cbf88d2 [app] [I] Current user: foreman_admin (administrator)
2017-06-02 14:47:11 6cbf88d2 [app] [W] Not all necessary pulp workers running at https://centos7-katello-3-4.example.com/pulp/api/v2/.
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.4.0.2/app/models/katello/ping.rb:130:in `pulp_without_auth'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.4.0.2/app/models/katello/ping.rb:38:in `block in ping_pulp_without_auth'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.4.0.2/app/models/katello/ping.rb:85:in `exception_watch'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.4.0.2/app/models/katello/ping.rb:37:in `ping_pulp_without_auth'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.4.0.2/app/models/katello/ping.rb:21:in `ping'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.4.0.2/app/lib/actions/middleware/backend_services_check.rb:13:in `block in plan'
 | /usr/share/foreman/app/models/concerns/foreman/thread_session.rb:75:in `as'
 | /usr/share/foreman/app/models/concerns/foreman/thread_session.rb:81:in `as_anonymous_admin'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.4.0.2/app/lib/actions/middleware/backend_services_check.rb:13:in `plan'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware/stack.rb:22:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware/stack.rb:26:in `pass'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware.rb:17:in `pass'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.4.0.2/app/lib/actions/middleware/remote_action.rb:9:in `plan'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware/stack.rb:22:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware/stack.rb:26:in `pass'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware.rb:17:in `pass'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware.rb:34:in `plan'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware/stack.rb:22:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware/stack.rb:26:in `pass'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware.rb:17:in `pass'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware.rb:34:in `plan'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware/stack.rb:22:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware/world.rb:30:in `execute'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/action.rb:466:in `block (2 levels) in execute_plan'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/execution_plan.rb:340:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/execution_plan.rb:340:in `switch_flow'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/action.rb:370:in `concurrence'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/action.rb:465:in `block in execute_plan'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/action.rb:425:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/action.rb:425:in `block in with_error_handling'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/action.rb:425:in `catch'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/action.rb:425:in `with_error_handling'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/action.rb:464:in `execute_plan'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/action.rb:266:in `execute'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/execution_plan/steps/plan_step.rb:54:in `block in execute'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/execution_plan/steps/abstract.rb:155:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/execution_plan/steps/abstract.rb:155:in `with_meta_calculation'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/execution_plan/steps/plan_step.rb:53:in `execute'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/action.rb:398:in `plan_action'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.4.0.2/app/lib/actions/katello/repository/create.rb:16:in `block in plan'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/execution_plan.rb:340:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/execution_plan.rb:340:in `switch_flow'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/action.rb:375:in `sequence'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.4.0.2/app/lib/actions/katello/repository/create.rb:14:in `plan'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/action.rb:467:in `block (3 levels) in execute_plan'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware/stack.rb:26:in `call'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-0.8.24/lib/dynflow/middleware/stack.rb:26:in `pass'

attached are pulp errors from /v/l/messages

pulp_probs.txt pulp_probs.txt 32.8 KB John Mitsch, 06/02/2017 10:53 AM

Related issues

Is duplicate of Katello - Bug #19938: race condition when starting pulp_resource_manager and pulp_celerybeat after installationClosed2017-06-06

History

#1 Updated by Eric Helms about 5 years ago

  • Legacy Backlogs Release (now unused) set to 228

#2 Updated by Eric Helms about 5 years ago

  • Status changed from New to Duplicate

#3 Updated by Eric Helms about 5 years ago

  • Is duplicate of Bug #19938: race condition when starting pulp_resource_manager and pulp_celerybeat after installation added

Also available in: Atom PDF