Project

General

Profile

Feature #1995

Enable parameterized class support by default

Added by Dominic Cleal over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
External Nodes
Target version:
Difficulty:
trivial
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Parameterized class support could probably be enabled by default relatively safely, given the age of 2.6.5 (minimum version required) and would be less surprising for new Foreman users trying to use it. Else, we could test the Puppet version when loading the default settings.


Related issues

Related to Foreman - Feature #832: parameterized class supportClosed2011-04-12
Related to Foreman - Bug #2140: Parametrized_Classes_in_ENC shouldn't be TRUE by defaultRejected2013-01-17

Associated revisions

Revision e36b9735 (diff)
Added by Dominic Cleal over 9 years ago

fixes #1995 - enable param class ENC by default on Puppet 2.6.5+

History

#1 Updated by Dominic Cleal over 9 years ago

  • Category set to External Nodes
  • Status changed from New to Assigned
  • Assignee set to Dominic Cleal

#2 Updated by Ohad Levy over 9 years ago

  • Target version set to 1.1

#3 Updated by Dominic Cleal over 9 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF