Project

General

Profile

Bug #19962

500 Internal Error - Candlepin

Added by Clayton Cowart about 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Virt-who fails with 500 Internal Error when trying to send to candlepin.

Production.log shows:

2017-06-07 03:21:42 8d7636c6 [katello/cp_proxy] [E] NoMethodError: undefined method `string' for #<PhusionPassenger::Utils::TeeInput:0x007fd38f5fcdb8> | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.4.0.2/app/controllers/katello/api/rhsm/candlepin_proxies_controller.rb:117:in `async_hypervisors_update'

production.tar.gz production.tar.gz 203 KB Clayton Cowart, 06/07/2017 07:48 PM

Related issues

Related to Katello - Bug #19963: Hypervisor can't report to katello Closed2017-06-08

History

#2 Updated by Clayton Cowart about 5 years ago

  • Description updated (diff)

#3 Updated by Mario Gamboa about 5 years ago

  • Related to Bug #19963: Hypervisor can't report to katello added

#4 Updated by Mario Gamboa about 5 years ago

fixed with this patch

diff --git a/app/controllers/katello/api/rhsm/candlepin_proxies_controller.rb b/app/controllers/katello/api/rhsm/candlepin_proxies_controller.rb
index 0d53b1c..5dd509b 100644
--- a/app/controllers/katello/api/rhsm/candlepin_proxies_controller.rb
+++ b/app/controllers/katello/api/rhsm/candlepin_proxies_controller.rb
@ -114,7 +114,7 @ module Katello # Note that this request comes in as content-type 'text/plain' so that # tomcat won't parse the json. Here we just pass the plain body through to candlepin
def async_hypervisors_update
- raw_json = request.body.string
+ raw_json = request.body.read
task = Katello::Resources::Candlepin::Consumer.async_hypervisors(params[:owner], raw_json)
async_task(::Actions::Katello::Host::Hypervisors, nil, :task_id => task['id'])

#5 Updated by Daniel Lobato Garcia about 5 years ago

  • Status changed from New to Duplicate

Should this be a duplicate of #19963? It looks like the same error. I'm closing it as dupe just in case, feel free to reopen if they are different.

Also available in: Atom PDF