Project

General

Profile

Bug #19971

Can't create repository within Product as non-admin user

Added by Brad Buckingham about 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Repositories
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1437134

Description of problem:
Cannot create repository within a product when granted full control through "product and repositories" filter (sync_products,create_products,edit_products,destroy_products,export_products)

Version-Release number of selected component (if applicable):
tested on 6.2.1 and 6.2.8

How reproducible:
every time

Steps to Reproduce:
1. User that is granted all permissions from "Product and repositories" filter
2. Create product
3. Create repository

Actual results:
"You are not authorized to perform this action"

Expected results:
Repository dialog allows user to create repo

Additional info:
User can create a product, and can successfully create product/repository through "Repo Discovery", but whenever trying to "Create Repository" within a product receiving error "You are not authorized to perform this action"

If an admin user creates the repository within the same product, the authorized user can modify,delete the repository.

Associated revisions

Revision 2e48f8e3 (diff)
Added by Brad Buckingham about 5 years ago

fixes #19971 - allow repo create by non-admin and fix delete

Attempting to create a repository as a non-admin user would
generate the following error:

RuntimeError: Could not find a smart proxy with pulp feature. | .../smart_proxy_extensions.rb:60:in `default_capsule!'

Since we do not want to now require the user to have
an additional permission on smart proxies, we chose
to treat the default capsule as an unscoped query.

Also, observed that the UI behavior for the repository
deletion permissions was incorrect. It was treating the
repo behavior based upon the product, which is determined
by all repos in that product vs the one the user is
working with.

History

#1 Updated by Brad Buckingham about 5 years ago

  • Subject changed from Can't create repository within Product to Can't create repository within Product as non-admin user
  • Target version set to 196

#2 Updated by The Foreman Bot about 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6817 added

#3 Updated by Brad Buckingham about 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Justin Sherrill about 5 years ago

  • Legacy Backlogs Release (now unused) set to 258

#5 Updated by Eric Helms about 5 years ago

  • Legacy Backlogs Release (now unused) changed from 258 to 267

#6 Updated by Eric Helms about 5 years ago

  • Legacy Backlogs Release (now unused) changed from 267 to 258

Also available in: Atom PDF