Project

General

Profile

Bug #20013

Notification polling duplicated on turbolinks navigation

Added by matan werbner over 1 year ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Notifications
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

since notification component is re-mounted, polling is re-initialised whenever turbolinks navigation occurs.


Related issues

Related to Foreman - Bug #20334: notification api promise was called incorrectly.Closed2017-07-18
Is duplicate of Foreman - Bug #18327: Notification polling request should not be initiated if there is an open turbolinks operationDuplicate2017-01-31

Associated revisions

Revision 13c542c2 (diff)
Added by matan werbner over 1 year ago

Fixes #20013 - Notification singleton polling

History

#1 Updated by Ohad Levy over 1 year ago

does this effect other components such as toast notifications? or maybe even host power ?

#2 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4588 added

#3 Updated by Ohad Levy over 1 year ago

  • Legacy Backlogs Release (now unused) set to 240

#4 Updated by matan werbner over 1 year ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Ohad Levy over 1 year ago

  • Related to Bug #20334: notification api promise was called incorrectly. added

#6 Updated by Daniel Lobato Garcia about 1 year ago

  • Category set to Notifications

#7 Updated by Ohad Levy 7 months ago

  • Is duplicate of Bug #18327: Notification polling request should not be initiated if there is an open turbolinks operation added

Also available in: Atom PDF