Project

General

Profile

Feature #20028

Need Katello size estimation script

Added by Andrew Kofink over 1 year ago. Updated 4 months ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
Upgrades
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Brad
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1390694
We need a simple script that users can run that can collect the following information:

1) Disk consumption and availability of the following directories:
/var/lib/pulp/
/var/lib/mongodb/
/var/lib/pgsql/
2) Disk speed using hdparm:
  1. hdparm -tT /dev/sda
/dev/sda:
Timing cached reads: 31332 MB in 2.00 seconds = 15689.05 MB/sec
Timing buffered disk reads: 466 MB in 3.01 seconds = 154.99 MB/sec
Not all Katello servers will have this installed so just automatically install it if you have to
3) Table sizes:
https://gist.github.com/mccun934/e93358be72902aa67dc450cb4f7c4574
cat tablesizes.sql | sudo -u postgres psql -d foreman
4) Table counts:
select count() from hosts;
select count(
) from dynflow_actions;
select count() from dynflow_steps;
select count(
) from katello_repositories;
A second phase would be to take these #s and calculate an estimated upgrade time but just gathering this data will be helpful and can be included in foreman-debug if possible.
A name like:
  1. katello-size-report
would be easy to remember

Related issues

Is duplicate of Foreman Maintain - Feature #20267: Need Foreman size estimation scriptReady For Testing

History

#1 Updated by Andrew Kofink over 1 year ago

  • Subject changed from Need Katello size estimation script to Need Katello size estimation script
  • Assignee set to Andrew Kofink
  • Target version set to 196

#2 Updated by Justin Sherrill over 1 year ago

  • Legacy Backlogs Release (now unused) set to 250

#3 Updated by Brad Buckingham over 1 year ago

  • Target version changed from 196 to 160

#4 Updated by Mike McCune over 1 year ago

  • Status changed from New to Closed

closing this out in favor of:

http://projects.theforeman.org/issues/20267

#5 Updated by Andrew Kofink about 1 year ago

  • Legacy Backlogs Release (now unused) deleted (250)

#6 Updated by Justin Sherrill about 1 year ago

  • Status changed from Closed to Duplicate
  • Legacy Backlogs Release (now unused) set to 166

#7 Updated by Justin Sherrill about 1 year ago

  • Is duplicate of Feature #20267: Need Foreman size estimation script added

Also available in: Atom PDF