Project

General

Profile

Bug #20067

NameError: wrong constant name Docker/ImageSearch on creating a new Role Filter

Added by Ondřej Pražák over 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
when clicking a 'New Filter' in the Role dialog, the following traceback is being logged in the production.log:
2017-06-13 05:07:24 cea0b842 [app] [W] unknown class Docker/ImageSearch, ignoring | NameError: wrong constant name Docker/ImageSearch | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/inflector/methods.rb:238:in `const_get' | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/inflector/methods.rb:238:in `block in constantize'
...

This seems to be happening during fetching the available filter list

Steps to Reproduce:
1. administer -> roles
2. click some role or create a new one
3. filters tab
4. click 'new filter' while watching production.log

Associated revisions

Revision 8ffd2fd6 (diff)
Added by Daniel Lobato García almost 4 years ago

Fixes #20067 - Wrong constant name Docker/ImageSearch

Revision 8ffd2fd6 (diff)
Added by Daniel Lobato García almost 4 years ago

Fixes #20067 - Wrong constant name Docker/ImageSearch

History

#1 Updated by Josh Pavel over 4 years ago

  • Subject changed from NameError: wrong constant name Docker/ImageSearch on creating a new Role Filter to NameError: wrong constant name Docker/ImageSearch on creating a new Role Filter

I'm hitting this issue too; I'm having problems with some role permissions, and I'm not clear if this is a symptom or a cause.

#2 Updated by The Foreman Bot almost 4 years ago

  • Assignee set to Daniel Lobato Garcia
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-docker/pull/205 added

#3 Updated by Anonymous almost 4 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF