Project

General

Profile

Bug #20091

`hammer package list --organization-id` results in 'Error: found more than one repository'

Added by Andrew Kofink about 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
medium
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Any use of --organization-id without --repository[id] (and --product[-id] as required) results in more than one repo being found for hammer package list.

Associated revisions

Revision ead760ff (diff)
Added by Andrew Kofink almost 5 years ago

Fixes #20091 - Require product to resolve repo

History

#1 Updated by Andrew Kofink about 5 years ago

  • Category set to Repositories
  • Assignee set to Andrew Kofink
  • Target version set to 196
  • Difficulty set to medium

This error is caused by multiple areas in hammer that require organization options for resolving repository ID. Rather, product options should be the only requirement. By extension, organization options should be required to resolve product ID.

#2 Updated by The Foreman Bot about 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/hammer-cli-katello/pull/502 added

#3 Updated by Eric Helms almost 5 years ago

  • Legacy Backlogs Release (now unused) set to 250

#4 Updated by Brad Buckingham almost 5 years ago

  • Target version changed from 196 to 202

#5 Updated by Andrew Kofink almost 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF