Project

General

Profile

Bug #20102

Capsule sync stops with a warning. Error "RestClient::MethodNotAllowed

Added by Anand Agrawal over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Capsule sync tasks complete with a warning. The error we see is on the "Actions::Pulp::Repository::Destroy" action . ===
Input:
---
pulp_id:
capsule_id: 2
remote_user: admin
remote_cp_user: admin
locale: en
Output:
---

Output:
---{}

Error:

RestClient::MethodNotAllowed

405 Method Not Allowed ===

As we can see the pulp_id parameter is empty for the task which seems to be likely cause of the error.

Version-Release number of selected component (if applicable):

Satellite 6.2.8

How reproducible:

Only reproducible in customers environment.

Actual results:
The sync completes with the warning "RestClient::MethodNotAllowed".

Expected results:
It should not give any warning messages.


Related issues

Is duplicate of Katello - Bug #20205: Capsule sync stops with a warning. Error "RestClient::MethodNotAllowed"Duplicate2017-07-05

Associated revisions

Revision 562e194c (diff)
Added by aagrawal over 4 years ago

Fixes #20102 - capsule sync- error RestClient::MethodNotAllowed

History

#1 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6838 added

#2 Updated by Eric Helms over 4 years ago

  • Legacy Backlogs Release (now unused) set to 267

#3 Updated by Anonymous over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Nagoor Shaik over 4 years ago

  • Related to Bug #20205: Capsule sync stops with a warning. Error "RestClient::MethodNotAllowed" added

#5 Updated by Nagoor Shaik over 4 years ago

  • Related to deleted (Bug #20205: Capsule sync stops with a warning. Error "RestClient::MethodNotAllowed")

#6 Updated by Nagoor Shaik over 4 years ago

  • Has duplicate Bug #20205: Capsule sync stops with a warning. Error "RestClient::MethodNotAllowed" added

#7 Updated by Nagoor Shaik over 4 years ago

  • Has duplicate deleted (Bug #20205: Capsule sync stops with a warning. Error "RestClient::MethodNotAllowed")

#8 Updated by Nagoor Shaik over 4 years ago

  • Is duplicate of Bug #20205: Capsule sync stops with a warning. Error "RestClient::MethodNotAllowed" added

#9 Updated by Eric Helms over 4 years ago

  • Legacy Backlogs Release (now unused) changed from 267 to 281

Also available in: Atom PDF