Project

General

Profile

Bug #20205

Capsule sync stops with a warning. Error "RestClient::MethodNotAllowed"

Added by Nagoor Shaik over 4 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Foreman Proxy Content
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Description of problem:

Capsule sync tasks complete with a warning. The error we see is on the "Actions::Pulp::Repository::Destroy" action . ===
Input:
---
pulp_id:
capsule_id: 2
remote_user: admin
remote_cp_user: admin
locale: en
Output:
---

Output:
---{}

Error:

RestClient::MethodNotAllowed

405 Method Not Allowed ===

As we can see the pulp_id parameter is empty for the task which seems to be likely cause of the error.

Version-Release number of selected component (if applicable):

Satellite 6.2.8

How reproducible:

Only reproducible in customers environment.

Actual results:
The sync completes with the warning "RestClient::MethodNotAllowed".

Expected results:
It should not give any warning messages.

Additional info:


Related issues

Has duplicate Katello - Bug #20102: Capsule sync stops with a warning. Error "RestClient::MethodNotAllowedClosed2017-06-24

History

#1 Updated by Nagoor Shaik over 4 years ago

  • Related to Bug #20102: Capsule sync stops with a warning. Error "RestClient::MethodNotAllowed added

#2 Updated by Nagoor Shaik over 4 years ago

  • Related to deleted (Bug #20102: Capsule sync stops with a warning. Error "RestClient::MethodNotAllowed)

#3 Updated by Nagoor Shaik over 4 years ago

  • Is duplicate of Bug #20102: Capsule sync stops with a warning. Error "RestClient::MethodNotAllowed added

#4 Updated by Nagoor Shaik over 4 years ago

  • Is duplicate of deleted (Bug #20102: Capsule sync stops with a warning. Error "RestClient::MethodNotAllowed)

#5 Updated by Nagoor Shaik over 4 years ago

  • Has duplicate Bug #20102: Capsule sync stops with a warning. Error "RestClient::MethodNotAllowed added

#6 Updated by Justin Sherrill over 4 years ago

  • Category set to Foreman Proxy Content
  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) set to 166

This seems like a dup. closing. Letme know if I am incorrect :)

Also available in: Atom PDF