Project

General

Profile

Bug #2029

Build PXE Default fails with "exp not empty after Safemode::Parser.process_call"...

Added by Dominic Cleal over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Templates
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Tested on develop (eefbf33f), clicking "Build PXE Default" under Provisioning Templates results in the following error:

failed to process template: exp not empty after Safemode::Parser.process_call on s(s(:call, s(:lvar, :profile), :[], s(:lit, :hostgroup))) from s(:call, nil, :default_template_url, s(:call, s(:lvar, :profile), :[], s(:lit, :template)), s(:call, s(:lvar, :profile), :[], s(:lit, :hostgroup)))

Related issues

Has duplicate Foreman - Bug #2082: PXE Default File seems to be brokenDuplicate2012-12-31
Blocked by Foreman - Bug #1834: Support for ruby 1.9.xClosed2012-08-23

History

#1 Updated by Dominic Cleal over 9 years ago

I can reproduce this with safemode 1.0.1 and ruby_parser 3.x, but not with safemode 1.1.0 and ruby_parser 3.x, or safemode 1.0.1 and ruby_parser 2.x.

#2 Updated by Ohad Levy over 9 years ago

  • Target version set to 1.1

#4 Updated by Dominic Cleal over 9 years ago

  • Status changed from Assigned to Resolved

This has been resolved via #1834 and Ruby 1.9 support. Update safemode to 1.1.0 and ruby_parser to 3.0.4.

Also available in: Atom PDF