Bug #20306

Satellite is not allowing recreation of SSH-key in Users

Added by Marek Hulán about 1 year ago. Updated 6 days ago.

Status:Closed
Priority:Normal
Assignee:Marek Hulán
Category:-
Target version:1.15.3
Difficulty: Team Backlog:
Triaged: Fixed in Releases:
Bugzilla link:1468541 Found in Releases:
Pull request:https://github.com/theforeman/foreman/pull/4671

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1468541

Description of problem:
Satellite is not allowing the recreation of SSH key after deleting that SSH key once from satellite.
It throws an error notification of 'Fingerprint has already been taken'.

Version-Release number of selected component (if applicable):
Satellite 6.3.0 Snap 5 / Foreman 1.15

How reproducible:
Always

Steps to Reproduce:
1. Create SSH key in any users(i tried in Admin) template
2. Delete that SSH key from users template.
3. Attempt to add same SSH key is same user template.

Actual results:
1. Satellite UI throws error notification - Fingerprint has already been taken.
2. SSH key is not added to user template.

Expected results:
Recreation/Re-Addition of SSH key in user template should be successful for any number of times. Error notification should not be displayed for recreation of SSH key.

Additional info:

The problem is that we enforce uniqueness throughout the application, if user A has the key, user B can't add it to his profile. I think we should run the validation only within owner scope.

Associated revisions

Revision a138f21c
Added by Marek Hulán 12 months ago

Fixes #20306 - allow the same key for two users

Revision cde470e7
Added by Marek Hulán 11 months ago

Fixes #20306 - allow the same key for two users

(cherry picked from commit a138f21cf7dcad13d5314c0b5c2a95ec98d94ed0)

History

#1 Updated by The Foreman Bot about 1 year ago

  • Status changed from New to Ready For Testing
  • Assignee set to Marek Hulán
  • Pull request https://github.com/theforeman/foreman/pull/4671 added

#2 Updated by Marek Hulán about 1 year ago

  • Subject changed from Satellite is not allowing recreation of SSH-key in Users to Satellite is not allowing recreation of SSH-key in Users
  • Legacy Backlogs Release (now unused) set to 276

if this is agreed on, I think we should make it 1.15.3 since 1.15 introduced ssh keys, please change the release if you disagree

#3 Updated by Marek Hulán 12 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF