Project

General

Profile

Bug #20410

Getting 403 forbidden error while setting the email preference or sending the test email with a normal user with viewer access

Added by Nagoor Shaik over 4 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Getting 403 forbidden error while setting the email preference or sending the test email with a normal user with viewer access logged in

Version-Release number of selected component (if applicable):
satellite 6.2.10

How reproducible:

Steps to Reproduce:
1. Added role view_mail_notifications only: no, mail button does NOT work, no test emails were sent.

2. With edit_user permission only: email button DOES works. Permission "view_mail_notifications" is NOT necessary for test emails.

3.

Actual results:

Getting 403 when assigned viewer role permission.

Expected results:

The view_mail_notifications role must be sufficient to send the test email.

Additional info:


Related issues

Is duplicate of Foreman - Bug #16807: test mail button requires excessive priviledgesClosed2016-10-05

History

#1 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4697 added

#2 Updated by Daniel Lobato Garcia over 4 years ago

  • Is duplicate of Bug #16807: test mail button requires excessive priviledges added

#3 Updated by Daniel Lobato Garcia over 4 years ago

  • Status changed from Ready For Testing to Duplicate

Closed as duplicate

Also available in: Atom PDF