Project

General

Profile

Actions

Bug #20491

closed

Inconsistent behavior of cancel and submit regarding search filters

Added by Kavita Gaikwad almost 7 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

There are 3 different behaviours for preserving search filters on 3 index pages:

Puppetclasses was fixed to save the search filter after edit if the submit or cancel button is clicked by: https://bugzilla.redhat.com/show_bug.cgi?id=1285013.

Hosts never save the search filter.
The submit on hosts does not go back to the index page so there is no need to save it but the cancel button should probably act the same as in puppetclass.

Hostgroups saves the filter when clicking cancel but not submit.

There should be consistent behaviour in the action the submit/cancel buttons use for all three.


Related issues 2 (0 open2 closed)

Related to Foreman - Bug #20728: Inconsistent behavior of cancel and submit regarding search filters - HostgroupClosedKavita GaikwadActions
Is duplicate of Foreman - Bug #20728: Inconsistent behavior of cancel and submit regarding search filters - HostgroupClosedKavita GaikwadActions
Actions #1

Updated by Kavita Gaikwad almost 7 years ago

  • Target version changed from 1.15.6 to 1.17.0
Actions #2

Updated by Kavita Gaikwad almost 7 years ago

  • Related to Bug #20728: Inconsistent behavior of cancel and submit regarding search filters - Hostgroup added
Actions #3

Updated by Kavita Gaikwad almost 7 years ago

  • Target version changed from 1.17.0 to 216
Actions #4

Updated by Kavita Gaikwad almost 7 years ago

  • Target version changed from 216 to 220
Actions #5

Updated by Kavita Gaikwad over 6 years ago

  • Target version changed from 220 to 230
Actions #6

Updated by Ondřej Ezr almost 5 years ago

  • Is duplicate of Bug #20728: Inconsistent behavior of cancel and submit regarding search filters - Hostgroup added
Actions #7

Updated by Ondřej Ezr almost 5 years ago

  • Category set to Web Interface
  • Status changed from New to Duplicate
  • Triaged set to No
Actions

Also available in: Atom PDF