Project

General

Profile

Feature #20577

hypervisors that do NOT have a subscription attached should NOT be green under content hosts

Added by Brad Buckingham about 5 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1336924

Description of problem:

When walking through virt-who steps, and then hypervisors populate into the satellite webui, they are always green. This is confusing since they should be red in our customers eyes since they don't have a subscription yet. So often times we'll have to have a remote session in order to explain to them "yes they are green, but you still have to attach a subscription to them"

Steps to Reproduce:
1. set up virt-who then start it
2. check under content hosts
3. all hypervisors show up and they are all green.

Actual results:

Even before adding a subscription, the status is green. On a regular content host they are red/yellow if they need a subscription. The hypervisors should be yellow, since they are in the webui, but need a subscription still.

Expected results:

status of yellow hypervisors, until you place a subscription on them.


Related issues

Is duplicate of Katello - Bug #17147: add non-green subscription status for unsubscribed_hypervisorClosed2016-10-31

History

#1 Updated by Brad Buckingham about 5 years ago

  • Subject changed from hypervisors that do NOT have a subscription attached should NOT be green under content hosts to hypervisors that do NOT have a subscription attached should NOT be green under content hosts
  • Target version set to 208

#2 Updated by Thomas McKay about 5 years ago

It has been suggested that a third color, perhaps grey, would be more appropriate for hosts with no installed products (such as hypervisors and non-RHEL hosts). Some design thought could be given to this topic in collaboration with the portal and candlepin team.

#3 Updated by Eric Helms about 5 years ago

  • Priority changed from High to Normal
  • Legacy Backlogs Release (now unused) set to 250

#4 Updated by Brad Buckingham almost 5 years ago

  • Target version changed from 208 to 213

#5 Updated by Brad Buckingham almost 5 years ago

  • Status changed from New to Duplicate

#6 Updated by Brad Buckingham almost 5 years ago

  • Is duplicate of Bug #17147: add non-green subscription status for unsubscribed_hypervisor added

#7 Updated by Brad Buckingham almost 5 years ago

  • Legacy Backlogs Release (now unused) changed from 250 to 166

Also available in: Atom PDF