Project

General

Profile

Bug #20586

Internal server error when viewing the activation-key host collections

Added by Brad Buckingham almost 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Activation Key
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Description of problem:
Activation-key Internal server error when viewing the added host collection

Version-Release number of selected component (if applicable):
  • candlepin-2.0.40-1.el7.noarch
  • candlepin-selinux-2.0.40-1.el7.noarch
  • foreman-1.15.2-1.el7sat.noarch
  • foreman-cli-1.15.2-1.el7sat.noarch
  • foreman-compute-1.15.2-1.el7sat.noarch
  • foreman-debug-1.15.2-1.el7sat.noarch
  • foreman-discovery-image-3.1.1-22.el7sat.noarch
  • foreman-ec2-1.15.2-1.el7sat.noarch
  • foreman-gce-1.15.2-1.el7sat.noarch
  • foreman-installer-1.15.2-1.el7sat.noarch
  • foreman-installer-katello-3.4.4-1.el7sat.noarch
  • foreman-libvirt-1.15.2-1.el7sat.noarch
  • foreman-openstack-1.15.2-1.el7sat.noarch
  • foreman-ovirt-1.15.2-1.el7sat.noarch
  • foreman-postgresql-1.15.2-1.el7sat.noarch
  • foreman-proxy-1.15.2-1.el7sat.noarch
  • foreman-rackspace-1.15.2-1.el7sat.noarch
  • foreman-selinux-1.15.2-1.el7sat.noarch
  • foreman-vmware-1.15.2-1.el7sat.noarch
  • katello-3.4.4-2.el7sat.noarch
  • katello-ca-consumer-sat-r220-02.lab.eng.rdu2.redhat.com-1.0-4.noarch
  • katello-certs-tools-2.4.0-1.el7sat.noarch
  • katello-client-bootstrap-1.4.0-1.el7sat.noarch
  • katello-common-3.4.4-2.el7sat.noarch
  • katello-debug-3.4.4-2.el7sat.noarch
  • katello-default-ca-1.0-1.noarch
  • katello-installer-base-3.4.4-1.el7sat.noarch
  • katello-selinux-3.0.2-1.el7sat.noarch
  • katello-server-ca-1.0-1.noarch
  • katello-service-3.4.4-2.el7sat.noarch
  • openldap-2.4.44-5.el7.x86_64
  • pulp-client-1.0-1.noarch
  • pulp-docker-plugins-2.3.0-1.el7sat.noarch
  • pulp-katello-1.0.2-1.el7sat.noarch
  • pulp-ostree-plugins-1.2.1-1.el7sat.noarch
  • pulp-puppet-plugins-2.12.2-1.el7sat.noarch
  • pulp-puppet-tools-2.12.2-1.el7sat.noarch
  • pulp-rpm-plugins-2.12.2-2.el7sat.noarch
  • pulp-selinux-2.12.2-2.el7sat.noarch
  • pulp-server-2.12.2-2.el7sat.noarch
  • python-ldap-2.4.15-2.el7.x86_64
  • tfm-rubygem-ldap_fluff-0.4.6-1.el7sat.noarch
  • tfm-rubygem-net-ldap-0.15.0-1.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a host collection
2. Create an Activation key
3. Open the created activation
4. Open the tab Host Collections
5. Open the sub-tab Add
6. The created host collection should be listed, selected it and press add selected button
7. Goto sub tab List/Remove

Actual results:
The host collection list is disabled and in console we can read:

bastion-013b148….js:2 GET https://sat-host/katello/api/v2/activation…ult=true&page=1&paged=true&per_page=20&search=&sort_by=name&sort_order=ASC 500 (Internal Server Error)

Expected results:
The added host collection listed


Related issues

Is duplicate of Katello - Bug #20580: "hammer host-collection list --host" produce error 500 - undefined method `order'Closed2017-08-14

History

#1 Updated by Brad Buckingham almost 5 years ago

  • Status changed from New to Duplicate

#2 Updated by Brad Buckingham almost 5 years ago

  • Is duplicate of Bug #20580: "hammer host-collection list --host" produce error 500 - undefined method `order' added

#3 Updated by Eric Helms almost 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF