Project

General

Profile

Bug #20597

Don't allow to run against different --target-version if one upgrade is already in progress

Added by Ivan Necas over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

At the moment, it's possible to end up in the middle of upgrade and
the upgrade prevent the user to specify different `--target-version`.

Steps to reproduce:

1. foreman-maintain upgrade run --target-version 6.2.z
2. simulate it failed in the migration phase
3. foreman-maintain upgrade --target-version 6.3

Current results:

The second upgrade scenario starts without issues.

Related issue to this is, when the upgrade fails at the installer run phase, the list of available versions
is already updated to the next versions, making it impossible to continue with the upgrade.

Expected results:

The upgrade to 6.3 will fail because another upgrade is already in progress

Associated revisions

Revision 3132f884 (diff)
Added by Ivan Necas about 4 years ago

Fixes #20597 - store the current target version of upgrade

This allows to prevent running one upgrade before finishing another one.
It also fixes an issue, where after updating the packages, one would not
be able to continue with the current upgrade when something goes wrong.

History

#1 Updated by Ivan Necas over 4 years ago

  • Description updated (diff)

#2 Updated by Ivan Necas over 4 years ago

  • Bugzilla link set to 1487539

#3 Updated by Ivan Necas over 4 years ago

  • Tracker changed from Feature to Bug

#4 Updated by Ivan Necas about 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_maintain/pull/95 added

#5 Updated by The Foreman Bot about 4 years ago

  • Assignee set to Ivan Necas

#6 Updated by Ivan Necas about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF