Project

General

Profile

Bug #20617

global variables: set the type

Added by Han Boetes almost 3 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

If I set the global variable http_proxy_port to 3142 and use it in the following puppet code:

  class { 'apt':
    proxy => {
      host => $http_proxy,
      port => 3142, # XXX $http_proxy_port,
      ensure => present,
    }
  }                                                                                                                                                                                    

I get this error: Server Error: Evaluation Error: Error while evaluating a Function Call, assert_type(): expects an Integer value, got String at /etc/puppetlabs/code/modules/apt/manifests/init.pp:75:5 on node

I would like to be able to set the type for global variables. Just like with smart class variables.


Related issues

Is duplicate of Foreman - Feature #4127: Array, Boolean and other types support in "hostgroup parameters"Closed

History

#1 Updated by Tomer Brisker almost 3 years ago

  • Is duplicate of Feature #4127: Array, Boolean and other types support in "hostgroup parameters" added

#2 Updated by Tomer Brisker almost 3 years ago

  • Project changed from Website to Foreman
  • Status changed from New to Duplicate

Setting to correct project and closing as duplicate.

Also available in: Atom PDF