Project

General

Profile

Feature #20618

global variables: set the type

Added by Han Boetes almost 3 years ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Puppet integration
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

If I set the global variable http_proxy_port to 3142 and use it in the following puppet code:

  class { 'apt':
    proxy => {
      host => $http_proxy,
      port => $http_proxy_port,
      ensure => present,
    }
  }                                                                                                                                                                                    

I get this error: Server Error: Evaluation Error: Error while evaluating a Function Call, assert_type(): expects an Integer value, got String at /etc/puppetlabs/code/modules/apt/manifests/init.pp:75:5 on node

I would like to be able to set the type for global variables. Just like with smart class variables.


Related issues

Is duplicate of Foreman - Feature #4127: Array, Boolean and other types support in "hostgroup parameters"Closed

History

#1 Updated by Ewoud Kohl van Wijngaarden almost 2 years ago

  • Category set to Puppet integration
  • Project changed from Website to Foreman
  • Tracker changed from Bug to Feature

#2 Updated by Tomer Brisker 9 months ago

  • Is duplicate of Feature #4127: Array, Boolean and other types support in "hostgroup parameters" added

#3 Updated by Tomer Brisker 9 months ago

  • Status changed from New to Resolved

This has been added in 1.22 as part of adding type support to parameters

Also available in: Atom PDF