Project

General

Profile

Feature #20690

add "elapsed time" column to task page for tasks

Added by Adam Ruzicka over 4 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Foreman plugin
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1474311

Description of problem:

When debugging issues, it's helpful to find tasks that take a long time to run. The following would be very useful:

  • a sortable/searchable 'elapsed time' column on the '/foreman_tasks/tasks' page, that subtracts the start time from end time if it exists, and start time from current time if there's no end time.
  • 'elapsed time' on the task export (not sure if this one is sortable, but just having the info there is helpful)

Version-Release number of selected component (if applicable): 6.2.10


Related issues

Is duplicate of foreman-tasks - Feature #27905: Add duration column to the tasks tableClosed

History

#1 Updated by Adam Ruzicka over 4 years ago

  • Category set to Foreman plugin
  • Target version set to 113

#2 Updated by Ori Rabin about 2 years ago

  • Is duplicate of Feature #27905: Add duration column to the tasks table added

#3 Updated by Adam Ruzicka 9 months ago

  • Triaged set to No
  • Status changed from New to Closed

This is a duplicate, closing.

Also available in: Atom PDF