Project

General

Profile

Bug #20704

PXE loader of host group is not viewable via REST api

Added by Jan Wenzel almost 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
API
Target version:
-
Difficulty:
trivial
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When retrieving the information of a hostgroup via the REST API, you don't see the currently selected PXE loader.

(like ticket #18658 but for hostgroups).

Fix is to add :pxe_loader to attributes in app/views/api/v2/hostgroups/main.json.rabl


Related issues

Is duplicate of Foreman - Bug #20858: Add pxe_loader field info into GET api of api/v2/hostgroups/:idClosed2017-09-05

History

#1 Updated by Kavita Gaikwad almost 4 years ago

  • Status changed from New to Duplicate

#2 Updated by Kavita Gaikwad almost 4 years ago

  • Is duplicate of Bug #20858: Add pxe_loader field info into GET api of api/v2/hostgroups/:id added

Also available in: Atom PDF