Project

General

Profile

Bug #20733

Create Docker container issues

Added by Dimitrij Artes over 4 years ago. Updated over 4 years ago.

Status:
New
Priority:
Normal
Category:
Plugin (foreman_docker)
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hey,

I'm using Foreman v1.15.3, Katello 3.4.4 and Docker plugin v3.2.1.
When i'm trying to create a container i get the errors in production.log:
  • Content View

API v1 - Repository images request failed

After setting Content View, Repo etc. and clicking 'Next step' the input is resetted, so it's not possible to create a container with Content View.

API v1 - Search failed

Although the searching for container fails searching for tags does not.
If i ignore the failed search and go to the next step creation of the container succeed.

docker_create_docker_hub_error.txt docker_create_docker_hub_error.txt 20.1 KB Trying to create container from Docker hub Dimitrij Artes, 08/24/2017 01:01 PM
docker_create_content_view_error.txt docker_create_content_view_error.txt 25.6 KB Trying to create container from Content View Dimitrij Artes, 08/24/2017 01:01 PM
docker_create_external_registry_error.txt docker_create_external_registry_error.txt 40.3 KB Trying to create container from External registry Dimitrij Artes, 08/24/2017 01:01 PM
create_docker_container.png View create_docker_container.png 56.7 KB Create container wizard Dimitrij Artes, 08/24/2017 01:24 PM
Create docker container

History

#1 Updated by Ivan Necas over 4 years ago

  • Project changed from Foreman to Docker
  • Category deleted (Compute resources)

#2 Updated by Joel Golden over 4 years ago

  • Assignee set to Daniel Lobato Garcia
  • Category set to Plugin (foreman_docker)

#3 Updated by Joel Golden over 4 years ago

I am having this same error under Katello 3.5 and Foreman 1.16.

System Information
Version 1.16.0 © 2009-2017 Paul Kelly and Ohad Levy

Installed Packages
candlepin-2.1.8-1.el7.noarch
candlepin-selinux-2.1.8-1.el7.noarch
foreman-1.16.0-1.el7.noarch
foreman-cli-1.16.0-1.el7.noarch
foreman-compute-1.16.0-1.el7.noarch
foreman-debug-1.16.0-1.el7.noarch
foreman-ec2-1.16.0-1.el7.noarch
foreman-installer-1.16.0-1.el7.noarch
foreman-installer-katello-3.5.0-3.el7.noarch
foreman-ovirt-1.16.0-1.el7.noarch
foreman-postgresql-1.16.0-1.el7.noarch
foreman-proxy-1.16.0-1.el7.noarch
foreman-release-1.16.0-1.el7.noarch
foreman-release-scl-3-1.el7.noarch
foreman-selinux-1.16.0-1.el7.noarch
foremanplv01.cjgolden.net-apache-1.0-1.noarch
foremanplv01.cjgolden.net-foreman-client-1.0-1.noarch
foremanplv01.cjgolden.net-qpid-broker-1.0-2.noarch
foremanplv01.cjgolden.net-qpid-client-cert-1.0-1.noarch
foremanplv01.cjgolden.net-qpid-router-client-1.0-1.noarch
foremanplv01.cjgolden.net-qpid-router-server-1.0-1.noarch
foremanplv01.cjgolden.net-tomcat-1.0-1.noarch
katello-3.5.0-2.el7.noarch
katello-certs-tools-2.4.0-1.el7.noarch
katello-client-bootstrap-1.3.0-1.el7.noarch
katello-common-3.5.0-2.el7.noarch
katello-debug-3.5.0-2.el7.noarch
katello-installer-base-3.5.0-3.el7.noarch
katello-repos-3.5.0-3.el7.noarch
katello-selinux-3.0.2-1.el7.noarch
katello-service-3.5.0-2.el7.noarch
pulp-client-1.0-1.noarch
pulp-docker-plugins-2.4.1-2.el7.noarch
pulp-katello-1.0.2-1.el7.noarch
pulp-puppet-plugins-2.13.4-1.el7.noarch
pulp-puppet-tools-2.13.4-1.el7.noarch
pulp-rpm-handlers-2.13.4-1.el7.noarch
pulp-rpm-plugins-2.13.4-1.el7.noarch
pulp-selinux-2.13.4-1.el7.noarch
pulp-server-2.13.4-1.el7.noarch
python-gofer-qpid-2.7.6-1.el7.noarch
python-isodate-0.5.0-4.pulp.el7.noarch
python-kombu-3.0.33-8.pulp.el7.noarch
python-pulp-agent-lib-2.13.4-1.el7.noarch
python-pulp-common-2.13.4-1.el7.noarch
python-pulp-docker-common-2.4.1-2.el7.noarch
python-pulp-oid_validation-2.13.4-1.el7.noarch
python-pulp-puppet-common-2.13.4-1.el7.noarch
python-pulp-repoauth-2.13.4-1.el7.noarch
python-pulp-rpm-common-2.13.4-1.el7.noarch
python-pulp-streamer-2.13.4-1.el7.noarch
python-qpid-1.36.0-1.el7.noarch
python-qpid-proton-0.17.0-4.el7.x86_64
python-qpid-qmf-1.36.0-1.el7.x86_64
qpid-cpp-client-1.36.0-1.el7.x86_64
qpid-cpp-client-devel-1.36.0-1.el7.x86_64
qpid-cpp-server-1.36.0-1.el7.x86_64
qpid-cpp-server-linearstore-1.36.0-1.el7.x86_64
qpid-dispatch-router-0.8.0-1.el7.x86_64
qpid-proton-c-0.17.0-4.el7.x86_64
qpid-qmf-1.36.0-1.el7.x86_64
qpid-tools-1.36.0-1.el7.noarch
rubygem-smart_proxy_pulp-1.3.0-1.el7.noarch
tfm-rubygem-activerecord-session_store-0.1.2-2.el7.noarch
tfm-rubygem-addressable-2.3.6-4.el7.noarch
tfm-rubygem-algebrick-0.7.3-4.el7.noarch
tfm-rubygem-ancestry-3.0.0-1.el7.noarch
tfm-rubygem-anemone-0.7.2-14.el7.noarch
tfm-rubygem-angular-rails-templates-1.0.2-1.el7.noarch
tfm-rubygem-apipie-bindings-0.2.0-1.el7.noarch
tfm-rubygem-apipie-params-0.0.5-1.el7.noarch
tfm-rubygem-apipie-rails-0.5.4-1.el7.noarch
tfm-rubygem-audited-4.4.1-1.el7.noarch
tfm-rubygem-awesome_print-1.7.0-1.el7.noarch
tfm-rubygem-bastion-6.1.5-1.fm1_16.el7.noarch
tfm-rubygem-bundler_ext-0.4.1-1.el7.noarch
tfm-rubygem-clamp-1.0.0-5.el7.noarch
tfm-rubygem-concurrent-ruby-1.0.3-1.fm1_16.el7.noarch
tfm-rubygem-concurrent-ruby-edge-0.2.3-1.el7.noarch
tfm-rubygem-css_parser-1.4.7-1.el7.noarch
tfm-rubygem-daemons-1.2.3-3.el7.noarch
tfm-rubygem-deacon-1.0.0-1.el7.noarch
tfm-rubygem-deep_cloneable-2.2.2-1.el7.noarch
tfm-rubygem-deface-1.2.0-1.el7.noarch
tfm-rubygem-docker-api-1.28.0-2.el7.noarch
tfm-rubygem-domain_name-0.5.20160310-1.el7.noarch
tfm-rubygem-dynflow-0.8.30-1.el7.noarch
tfm-rubygem-excon-0.58.0-1.el7.noarch
tfm-rubygem-facter-2.4.0-4.el7.x86_64
tfm-rubygem-fast_gettext-1.4.1-1.el7.noarch
tfm-rubygem-fog-1.41.0-2.el7.noarch
tfm-rubygem-fog-aws-1.3.0-1.el7.noarch
tfm-rubygem-fog-core-1.45.0-1.el7.noarch
tfm-rubygem-fog-digitalocean-0.3.0-1.el7.noarch
tfm-rubygem-fog-google-0.1.0-2.el7.noarch
tfm-rubygem-fog-json-1.0.2-4.el7.noarch
tfm-rubygem-fog-openstack-0.1.18-1.el7.noarch
tfm-rubygem-fog-rackspace-0.1.4-1.el7.noarch
tfm-rubygem-fog-vsphere-1.9.2-1.el7.noarch
tfm-rubygem-fog-xenserver-0.2.3-1.el7.noarch
tfm-rubygem-fog-xml-0.1.2-4.el7.noarch
tfm-rubygem-foreman-tasks-0.10.0-2.fm1_16.el7.noarch
tfm-rubygem-foreman-tasks-core-0.2.0-1.fm1_16.el7.noarch
tfm-rubygem-foreman_ansible-1.4.5-1.fm1_16.el7.noarch
tfm-rubygem-foreman_ansible_core-1.1.1-1.fm1_16.el7.noarch
tfm-rubygem-foreman_bootdisk-10.0.1-1.fm1_16.el7.noarch
tfm-rubygem-foreman_discovery-10.0.0-1.fm1_16.el7.noarch
tfm-rubygem-foreman_docker-3.2.1-1.fm1_16.el7.noarch
tfm-rubygem-formatador-0.2.1-9.el7.noarch
tfm-rubygem-friendly_id-5.1.0-3.el7.noarch
tfm-rubygem-get_process_mem-0.2.1-1.el7.noarch
tfm-rubygem-gettext_i18n_rails-1.2.1-3.el7.noarch
tfm-rubygem-hammer_cli-0.11.0-1.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.11.0-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-5.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.4-2.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.12-1.fm1_16.el7.noarch
tfm-rubygem-hammer_cli_katello-0.11.4-1.el7.noarch
tfm-rubygem-hashie-2.0.5-4.el7.noarch
tfm-rubygem-highline-1.7.8-2.el7.noarch
tfm-rubygem-http-cookie-1.0.2-1.el7.noarch
tfm-rubygem-ipaddress-0.8.0-9.el7.noarch
tfm-rubygem-katello-3.5.0.1-1.el7.noarch
tfm-rubygem-ldap_fluff-0.4.7-1.el7.noarch
tfm-rubygem-little-plugger-1.1.3-21.el7.noarch
tfm-rubygem-locale-2.0.9-11.el7.noarch
tfm-rubygem-logging-1.8.2-4.el7.noarch
tfm-rubygem-net-ldap-0.15.0-1.el7.noarch
tfm-rubygem-net-ping-2.0.1-1.el7.noarch
tfm-rubygem-net-scp-1.2.1-1.el7.noarch
tfm-rubygem-net-ssh-4.0.1-1.el7.noarch
tfm-rubygem-netrc-0.11.0-1.el7.noarch
tfm-rubygem-oauth-0.5.1-1.el7.noarch
tfm-rubygem-parse-cron-0.1.4-2.fm1_11.el7.noarch
tfm-rubygem-passenger-4.0.18-9.11.el7.x86_64
tfm-rubygem-passenger-native-4.0.18-9.11.el7.x86_64
tfm-rubygem-passenger-native-libs-4.0.18-9.11.el7.x86_64
tfm-rubygem-pg-0.15.1-3.el7.x86_64
tfm-rubygem-powerbar-1.0.17-1.el7.noarch
tfm-rubygem-puppetdb_foreman-3.0.2-1.fm1_16.el7.noarch
tfm-rubygem-qpid_messaging-0.34.1-1.el7.x86_64
tfm-rubygem-rabl-0.12.0-2.el7.noarch
tfm-rubygem-rack-jsonp-1.3.1-5.el7.noarch
tfm-rubygem-rails-i18n-4.0.9-1.el7.noarch
tfm-rubygem-rainbow-2.2.1-1.el7.noarch
tfm-rubygem-rbovirt-0.1.3-1.el7.noarch
tfm-rubygem-rbvmomi-1.10.0-1.el7.noarch
tfm-rubygem-responders-2.3.0-1.el7.noarch
tfm-rubygem-rest-client-2.0.1-1.el7.noarch
tfm-rubygem-roadie-3.2.1-1.el7.noarch
tfm-rubygem-roadie-rails-1.1.1-1.el7.noarch
tfm-rubygem-robotex-1.0.0-19.el7.noarch
tfm-rubygem-ruby2ruby-2.1.3-4.el7.noarch
tfm-rubygem-ruby_parser-3.6.3-4.el7.noarch
tfm-rubygem-runcible-2.5.0-1.el7.noarch
tfm-rubygem-safemode-1.3.1-1.el7.noarch
tfm-rubygem-scoped_search-4.1.0-1.el7.noarch
tfm-rubygem-secure_headers-3.4.1-1.el7.noarch
tfm-rubygem-sequel-4.20.0-5.el7.noarch
tfm-rubygem-sexp_processor-4.4.4-3.el7.noarch
tfm-rubygem-smart_proxy_dynflow_core-0.1.7-1.fm1_16.el7.noarch
tfm-rubygem-sprockets-rails-3.2.0-1.el7.noarch
tfm-rubygem-sshkey-1.9.0-1.el7.noarch
tfm-rubygem-trollop-2.1.2-1.el7.noarch
tfm-rubygem-unf-0.1.3-5.el7.noarch
tfm-rubygem-unf_ext-0.0.6-6.el7.x86_64
tfm-rubygem-unicode-display_width-1.0.5-1.el7.noarch
tfm-rubygem-useragent-0.16.8-1.el7.noarch
tfm-rubygem-validates_lengths_from_database-0.5.0-3.el7.noarch
tfm-rubygem-webpack-rails-0.9.8-1.el7.noarch
tfm-rubygem-wicked-1.1.0-4.el7.noarch
tfm-rubygem-will_paginate-3.1.5-1.el7.noarch
tfm-rubygem-x-editable-rails-1.5.5-1.el7.noarch
tfm-runtime-3.2-10.el7.x86_64

#4 Updated by Joel Golden over 4 years ago

This error occurs after typing content into the search field. If you supply a correct image name into the search field you can arrow up / down in the tag field and it will allow you to select the available images.

Also available in: Atom PDF