Project

General

Profile

Feature #20773

Support for Private Repos at Docker Hub

Added by Sebastian Gräßl almost 5 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1475121

Description of problem:
Satellite 6 is not able to sync private registry hosted on Docker Hub.

Version-Release number of selected component (if applicable):

How reproducible:
Allways

Steps to Reproduce:
1. Create a registry on https://hub.docker.com
2. Push an image in the registry and make the registry private
3. Create the Docker type repository in the Satellite pointing to the private registry
4. Try to sync the repository

Actual results:
Sync fails with following error:
Could not fetch repository username/registry from registry https://registry.hub.docker.com - Unauthorized or Not Found

Expected results:

  • Unauthorized access is documented.
  • Registry is synced.

Additional info:
- Registry entry in Containers > Registries is created and credentials are correct.
- If the registry is not set as Private, sync is working without any issues
- Pulling from the private registry works

History

#1 Updated by Sebastian Gräßl almost 5 years ago

  • Subject changed from Support for Private Repos at Docker Hub to Support for Private Repos at Docker Hub
  • Status changed from New to Rejected

#2 Updated by Marek Hulán almost 5 years ago

Sebastian, what was the reason for rejecting the issue?

#3 Updated by Sebastian Gräßl almost 5 years ago

@Marek: I copied the wrong ID and couldn't kill the script anymore. The BZ is about syncing of private repos via pulp. Private repos on Docker hub work with foreman-docker, however it is not explicitly documented.

Also available in: Atom PDF