Project

General

Profile

Feature #20774

Docker api gem supports api version 1.24

Added by Sebastian Gräßl almost 5 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1483817

Description of problem:
Currently the docker api gem has a hard coded api version of 1.16. If the docker server is using the api 1.24 version, the following error will be raised when trying to create a docker compute resource in the Satellite Web UI:

client version 1.16 is too old. Minimum supported API version is 1.19, please upgrade your client to a newer version

  1. cd /opt/theforeman/tfm/root/usr/share/gems/gems/docker-api-1.28.0/lib/docker
  2. grep -rin --color "API_VERSION" *
    connection.rb:83: :path => "/v#{Docker::API_VERSION}#{path}",
    version.rb:6: API_VERSION = '1.16'

Also available in: Atom PDF