Project

General

Profile

Bug #20831

host's tracer list fails with error

Added by Justin Sherrill about 4 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Category:
-
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Trying to access a host's tracer list results in error:

2017-09-01 17:11:28 eb37fa5b [app] [E] NoMethodError: undefined method `order' for #<Array:0x007fc3743750c0>
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.4.4/app/controllers/katello/api/v2/api_controller.rb:73:in `scoped_search'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.4.4/app/controllers/katello/api/v2/host_tracer_controller.rb:15:in `index'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/actionpack-4.2.6/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/actionpack-4.2.6/lib/abstract_controller/base.rb:198:in `process_action'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/actionpack-4.2.6/lib/action_controller/metal/rendering.rb:10:in `process_action'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/actionpack-4.2.6/lib/abstract_controller/callbacks.rb:20:in `block in process_action'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/activesupport-4.2.6/lib/active_support/callbacks.rb:117:in `call'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/activesupport-4.2.6/lib/active_support/callbacks.rb:555:in `block (2 levels) in compile'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/activesupport-4.2.6/lib/active_support/callbacks.rb:505:in `call'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/activesupport-4.2.6/lib/active_support/callbacks.rb:498:in `block (2 levels) in around'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/activesupport-4.2.6/lib/active_support/callbacks.rb:313:in `block (2 levels) in halting'
 | /usr/share/foreman/app/controllers/api/v2/base_controller.rb:152:in `disable_json_root'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/activesupport-4.2.6/lib/active_support/callbacks.rb:432:in `block in make_lambda'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/activesupport-4.2.6/lib/active_support/callbacks.rb:312:in `block in halting'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/activesupport-4.2.6/lib/active_support/callbacks.rb:497:in `block in around'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/activesupport-4.2.6/lib/active_support/callbacks.rb:505:in `call'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/activesupport-4.2.6/lib/active_support/callbacks.rb:498:in `block (2 levels) in around'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/activesupport-4.2.6/lib/active_support/callbacks.rb:313:in `block (2 levels) in halting'
 | /usr/share/foreman/app/controllers/concerns/application_shared.rb:15:in `set_timezone'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/activesupport-4.2.6/lib/active_support/callbacks.rb:432:in `block in make_lambda'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/activesupport-4.2.6/lib/active_support/callbacks.rb:312:in `block in halting'
 | /opt/rh/rh-ror42/root/usr/share/gems/gems/activesupport-4.2.6/lib/active_support/callbacks.rb:497:in `block in 

Related issues

Has duplicate Katello - Bug #20860: Traces doesn't workDuplicate2017-09-06
Is duplicate of Katello - Bug #20703: Content Hosts Traces page doesnt workClosed2017-08-23

History

#1 Updated by Justin Sherrill about 4 years ago

  • Assignee set to Justin Sherrill
  • Legacy Backlogs Release (now unused) set to 295
  • Difficulty set to easy

#2 Updated by Brad Buckingham about 4 years ago

  • Bugzilla link set to 1489133

#3 Updated by Justin Sherrill about 4 years ago

  • Has duplicate Bug #20860: Traces doesn't work added

#4 Updated by Brad Buckingham about 4 years ago

  • Status changed from New to Duplicate

#5 Updated by Brad Buckingham about 4 years ago

  • Bugzilla link deleted (1489133)

#6 Updated by Brad Buckingham about 4 years ago

  • Legacy Backlogs Release (now unused) changed from 295 to 166

#7 Updated by Brad Buckingham about 4 years ago

  • Is duplicate of Bug #20703: Content Hosts Traces page doesnt work added

Also available in: Atom PDF