Project

General

Profile

Bug #2090

Dashboard dosen't work

Added by Alexander Litvinenko over 6 years ago. Updated over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Dashboard stopped working. Error when accessing dashboard is "divided by 0", in trace is:

ZeroDivisionError
divided by 0
app/helpers/dashboard_helper.rb:8:in `/'
app/helpers/dashboard_helper.rb:8:in `count_reports'
app/views/dashboard/index.html.erb:40:in `_app_views_dashboard_index_html_erb___1264836471_70197812643080_0'
app/controllers/dashboard_controller.rb:6:in `index'
lib/foreman/threadsession.rb:31:in `clear_thread'

Other tabs like hosts, reports, facts, etc. is working like as usual.


Related issues

Is duplicate of Foreman - Bug #1475: Can't set the puppet_run interval to less than 10.Resolved2012-01-29

History

#1 Updated by Sam Kottler over 6 years ago

  • Assignee deleted (Ohad Levy)
  • Target version set to 1.1

Can you give more information about your environment? How many hosts do you have, etc?

#2 Updated by Alexander Litvinenko over 6 years ago

It's not production env., first attempts with puppet and foreman.

debian squeeze, foreman 1.1 nightly from deb repo., puppet 3.0.2, ~20 hosts.

Problem appear when i deleted some classes from foreman by hands.

#3 Updated by Alexander Litvinenko over 6 years ago

It's not production env., first attempts with puppet and foreman.

debian squeeze, foreman 1.1 nightly from deb repo., puppet 3.0.2, ~20 hosts.

Problem appear when i deleted some classes from foreman by hands.

#4 Updated by Ohad Levy over 6 years ago

  • Status changed from New to Duplicate
  • Target version deleted (1.1)

Also available in: Atom PDF