Project

General

Profile

Bug #20972

STI issues with Host::Discovered on Rails 5

Added by Tomer Brisker almost 3 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

test (and most likely other parts) fail with:

Invalid single-table inheritance type: Host::Discovered is not a subclass of Host::Managed


Related issues

Related to Foreman - Bug #21037: "Invalid single-table inheritance type: Host::Discovered is not a subclass of Host::Managed" caused by auditing hostClosed
Blocks Foreman - Tracker #15715: Rails 5.0 upgrade tasksResolved2016-07-18

History

#1 Updated by Tomer Brisker almost 3 years ago

#2 Updated by Lukas Zapletal almost 3 years ago

Just for the record, this might be related (a possible fix) https://github.com/theforeman/foreman/pull/4822/files

#3 Updated by Ivan Necas almost 3 years ago

  • Related to Bug #21037: "Invalid single-table inheritance type: Host::Discovered is not a subclass of Host::Managed" caused by auditing host added

#4 Updated by Ivan Necas almost 3 years ago

The fix addressing the issue is here https://github.com/theforeman/foreman/pull/4864, once merged, we can mark this as dupe of #21037

#5 Updated by Lukas Zapletal almost 3 years ago

  • Status changed from New to Duplicate

Problem solved upstream.

Also available in: Atom PDF