Project

General

Profile

Bug #21016

Unable to update host's content source via hammer

Added by Brad Buckingham about 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hosts
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1488465
Refer to bugzilla for additional details.

Description of problem:
`hammer host update --content-source-id` seems to have no effect - command finishes successfully but content source is not changed on WebUI (currently it's the only place where it's possible to check content source due to #1488150 and #1488130 ).

Version-Release number of selected component (if applicable):
Satellite 6.3.0 Snap 14

How reproducible:
Always

Steps to Reproduce:
1. Create a host (with or without content source specified, doesn't matter)
2. Update host's content source via hammer:
hammer host update --id="115" --content-source-id="23"
3. Go to WebUI, Hosts -> All hosts -> #host_name# -> Edit, check selected content source.

Actual results:
Although update command finished with successful message ('Host updated'), content source was not changed.

Expected results:
Content source was changed.

Additional info:
Refer to bugzilla for additonal details.

Associated revisions

Revision b4cacd27 (diff)
Added by Partha Aji almost 4 years ago

Fixes #21016 - Can update content source in host

Prior to this commit a simple call like
hammer host update --id=1 --content-source-id=2
would fail because the content facet nested attributes code would reject
updating any request that did not contain a content-view-id or a
lifecycle-environment-id. This code fixes that by updating the model to
say "if content facet is present update any changes that come in Else
check on cv-id and environment"

History

#1 Updated by Brad Buckingham about 4 years ago

  • Subject changed from Unable to update host's content source via hammer to Unable to update host's content source via hammer
  • Target version set to 217

#2 Updated by Justin Sherrill about 4 years ago

  • Legacy Backlogs Release (now unused) set to 250

#3 Updated by Partha Aji almost 4 years ago

  • Assignee set to Partha Aji

#4 Updated by The Foreman Bot almost 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6976 added

#5 Updated by Partha Aji almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF