Project

General

Profile

Bug #21080

clean_installed_packages script will not exit after foreign key error

Added by Chris Duryee almost 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

In http://projects.theforeman.org/issues/20946, we tried to make the clean_installed_packages script more resilient against foreign key errors. However, there is a bug that causes the script to keep increasing its batch size without removing old entries from its query, so problematic keys never get taken off the list.

Associated revisions

Revision 0fc161c1 (diff)
Added by Chris Duryee almost 5 years ago

Fixes #21080 - exit out after foreign key error

Previously, we attempted to gracefully handle foreign key errors that
usually are caused by client checkins during the cleanup script's run.
This "graceful" handling had a bug that caused it to error on every
subsequent batch.

Instead, simply exit and tell the user to re-run the script.

History

#1 Updated by The Foreman Bot almost 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6971 added

#2 Updated by Chris Duryee almost 5 years ago

  • Bugzilla link set to 1483677

#3 Updated by Chris Duryee almost 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Justin Sherrill almost 5 years ago

  • Legacy Backlogs Release (now unused) set to 295

Also available in: Atom PDF