Project

General

Profile

Actions

Feature #2113

closed

Better VMWare Datastore UI

Added by Josh Baird over 11 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources - VMware
Target version:
-
Fixed in Releases:
Found in Releases:

Description

When picking a datastore to use on a VMWare compute resource, the list of Data Store's should only contain Data Stores that are valid for the particular cluster that the user picked. Instead, it displays a list of all data stores associated with the vSphere instance (multiple clusters). This allows for user error which results in a weird obscure error in Foreman and vSphere.

Additionally, it would be nice if we could show free space information for each data store. This would help the user decide which Data Store the new VM should be placed in.


Related issues 5 (1 open4 closed)

Related to Foreman - Bug #19424: VMware provisioning displays all IP addressNewTimo Goebel04/28/2017Actions
Related to Foreman - Feature #23369: load vmware datastore options asynchronouslyClosedTimo GoebelActions
Has duplicate Foreman - Bug #2178: VMware - Cluster and asociated datastoresDuplicate02/04/2013Actions
Has duplicate Foreman - Feature #2886: Support for VMWare data store clustersDuplicate08/06/2013Actions
Has duplicate Foreman - Feature #15115: Filter datastore and network selection Duplicate05/20/2016Actions
Actions #1

Updated by Sam Kottler over 11 years ago

  • Target version set to 1.2.0

These are all great suggestions that we should work on. Since we are getting close to the 1.1 final release, I'm adding this to the 1.2 backlog.

Actions #2

Updated by Dominic Cleal about 11 years ago

  • Target version deleted (1.2.0)
Actions #3

Updated by Dominic Cleal almost 11 years ago

  • Has duplicate Feature #2886: Support for VMWare data store clusters added
Actions #4

Updated by Josh Baird almost 11 years ago

Additional request - user should have the option to thin or thick provision storage. Currently, everything is thin provisioned with no option to thick provision.

Actions #5

Updated by Dmitry Sakun over 10 years ago

Voting for this one as it's really nice to have this feature otherwise you still have to look into vsphere for a datastore and that breaks the idea of foreman.
May be adding some caching mechanism for the volumes and networks will improve the speed of enumeration process which may take a long time in big Datacenters.

Actions #6

Updated by Derek Wright about 10 years ago

1, I'm working on rolling Foreman out to our production data store and I've noticed when we have hundreds of datastores/networks in our vcenter it slows things down considerably. It seems to really be a pain point for people when trying to use the UI and loading the compute profile takes about 30 secs. If it could load only relevant resources for the datacenter selected, load times may increase.

Info from log:
Started GET "/hosts/hostname.domain.com/edit" for x.x.x.x at 2014-05-19 10:27:43 -0400
Processing by HostsController#edit as HTML
Parameters: {"id"=>"hostname.domain.com"}
Rendered hosts/_progress.html.erb (0.1ms)
Rendered puppetclasses/_selectedClasses.html.erb (0.0ms)
Rendered puppetclasses/_classes_in_groups.html.erb (0.0ms)
Rendered puppetclasses/_classes.html.erb (6.5ms)
Rendered puppetclasses/_class_selection.html.erb (111.4ms)
Successfully decrypted field for Foreman::Model::Vmware Company-WDC-Core
Rendered compute_resources_vms/form/vmware/_network.html.erb (2732.7ms)
Rendered compute_resources_vms/form/vmware/_network.html.erb (2718.9ms)
Rendered compute_resources_vms/form/vmware/_volume.html.erb (16939.5ms)
Rendered compute_resources_vms/form/vmware/_volume.html.erb (18282.3ms)
Rendered compute_resources_vms/form/vmware/_volume.html.erb (17240.1ms)
Rendered compute_resources_vms/form/_vmware.html.erb (59663.2ms)
Rendered hosts/_compute.html.erb (60428.7ms)
Rendered common/_domain.html.erb (23.2ms)
Rendered hosts/_interfaces.html.erb (13.3ms)
Rendered common/os_selection/_architecture.html.erb (4.5ms)
Rendered common/os_selection/_operatingsystem.html.erb (12.9ms)
Rendered hosts/_operating_system.html.erb (23.0ms)
Rendered hosts/_unattended.html.erb (60518.2ms)
Rendered puppetclasses/_class_parameters.html.erb (0.0ms)
Rendered puppetclasses/_classes_parameters.html.erb (15.3ms)
Rendered common_parameters/_inherited_parameters.html.erb (135.1ms)
Rendered common_parameters/_puppetclass_parameter.html.erb (2.7ms)
Rendered common_parameters/_puppetclasses_parameters.html.erb (6.4ms)
Rendered common_parameters/_parameter.html.erb (1.5ms)
Rendered common_parameters/_parameters.html.erb (5.0ms)
Rendered hosts/_form.html.erb (60901.7ms)
Rendered hosts/edit.html.erb within layouts/application (60903.9ms)
Rendered home/_user_dropdown.html.erb (2.2ms)
Read fragment views/tabs_and_title_records-5 (0.2ms)
Rendered home/_topbar.html.erb (3.9ms)
Rendered layouts/base.html.erb (6.1ms)
Completed 200 OK in 60933ms (Views: 60884.6ms | ActiveRecord: 31.4ms)

Actions #7

Updated by Virgil Chereches about 9 years ago

+1 for datastore cluster support

Actions #8

Updated by larry campbell almost 9 years ago

1 for datastore cluster filter from me as well. I notice this feature request has 11 votes and still hasn't been assigned in 2 years... is there another issue blocking or duplicate of this?

Actions #9

Updated by Anonymous over 8 years ago

  • Description updated (diff)

It's mostly limited by the developer's time looking into it, maybe this also requires changes to fog (I don't know!). Like every open source project we are more than willing to accept pull requests also for this issue, there has just to be somebody who is doing all the work at the end...

Actions #10

Updated by Anonymous over 8 years ago

  • Category changed from VM management to Compute resources - VMware
Actions #11

Updated by Timo Goebel about 8 years ago

  • Has duplicate Feature #15115: Filter datastore and network selection added
Actions #12

Updated by Timo Goebel about 8 years ago

  • Assignee set to Timo Goebel
Actions #13

Updated by Angelo Lisco about 8 years ago

As I requested though #15115, a filtered selection would also be really useful on the network tab as well.
Thank you Timo for taking care of this ;)

Actions #14

Updated by The Foreman Bot almost 8 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3559 added
Actions #15

Updated by Angelo Lisco about 7 years ago

  • Related to Bug #19424: VMware provisioning displays all IP address added
Actions #16

Updated by Marek Hulán over 6 years ago

  • Bugzilla link set to 1489516
Actions #17

Updated by Daniel Lobato Garcia over 6 years ago

  • Bugzilla link changed from 1489516 to 1467709
Actions #18

Updated by Timo Goebel about 6 years ago

  • Related to Feature #23369: load vmware datastore options asynchronously added
Actions #19

Updated by Marek Hulán over 5 years ago

  • Bugzilla link changed from 1467709 to 1489516
Actions #20

Updated by The Foreman Bot over 5 years ago

  • Pull request https://github.com/theforeman/foreman/pull/6442 added
Actions #21

Updated by Marek Hulán over 5 years ago

  • Fixed in Releases 1.22.0 added
Actions #22

Updated by Ondřej Ezr over 5 years ago

  • Status changed from Ready For Testing to Closed
Actions

Also available in: Atom PDF