Project

General

Profile

Bug #21140

If you are in org foo, you cannot delete org bar if bar has systems in it.

Added by Daniel Lobato Garcia over 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Organizations and Locations
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1424607

Description of problem:
If you are in org foo, you cannot delete org bar if bar has systems in it. When you're at
https://satellite.example.com/organizations
and you're in one org, all other orgs will show as having 0 systems even if they do have systems. If you try to delete one of those orgs with systems, you'll get an error:
Oops, we're sorry but something went wrong Value (NilClass) '' is not any of: ForemanTasks::Concerns::ActionSubject.

The full trace is attached.

How reproducible:
100%

Steps to Reproduce:
1. In your satellite, select one of your orgs
2. Go to manage organizations
3. Try to delete one of your other organizations that has systems.

Actual results:
Error as posted above.

Expected results:
If it is a permissions issue (even though I'm admin and can just as easily select that other org to be in), then a nice permissions denied message should be displayed, not a traceback.

Additional info:


Related issues

Is duplicate of Katello - Bug #15340: Org destroy not unassociating host groupsClosed2016-06-07

History

#1 Updated by Justin Sherrill over 4 years ago

  • Subject changed from If you are in org foo, you cannot delete org bar if bar has systems in it. to If you are in org foo, you cannot delete org bar if bar has systems in it.
  • Assignee changed from Thomas McKay to Partha Aji
  • Target version set to 217

#2 Updated by Partha Aji over 4 years ago

  • Is duplicate of Bug #15340: Org destroy not unassociating host groups added

#3 Updated by Partha Aji over 4 years ago

  • Status changed from New to Duplicate

This issue should have been resolved by the fix for http://projects.theforeman.org/issues/15340 . Reopen if it persists.

#4 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF