Project

General

Profile

Bug #21165

Unable to view the content-source information from hammer host info

Added by Tomáš Strachota over 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
Hammer
Target version:
Difficulty:
trivial
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1483252

Description of problem:

Unable to view the content-source information from hammer host info

~]# hammer -u admin -p changeme host info --id 3
Id:                       3
UUID:                     b81f8c0d-6622-43a0-acc1-7c5228f9ed4b
Name:                     sara-volking.domain.redhat.com
Organization:             Default Organization
Location:                 Default Location
Host Group:               RHEL 7 Server 64-bit HG
Compute Resource:         libvirt
Environment:              production
Puppet CA Id:             1
Puppet Master Id:         1
Cert name:                sara-volking.domain.redhat.com
Managed:                  yes
Installed at:             
Last report:              
Network:                  
    IP:     10.x.x.x
    MAC:    52:54:xx:yy:zz:aa
    Subnet: katello_latest
    Domain: satqe.lab.eng.rdu2.redhat.com
Network interfaces:       
 1) Id:          3
    Identifier:  
    Type:        interface (primary, provision)
    MAC address: 52:54:xx:yy:zz:aa
    IP address:  10.x.x.x
    FQDN:
Operating system:         
    Architecture:           x86_64
    Operating System:       RedHat 7.3
    Build:                  yes
    Partition Table:        Kickstart default
    Custom partition table:
Parameters:               

Additional info:
    Owner Id:   3
    Owner Type: User
    Enabled:    yes
    Comment:
Content Information:      
    Content View:          RHEL 7 CV
    Lifecycle Environment: DEV
    Applicable Packages:   0
    Upgradable Packages:   0
    Applicable Errata:     
        Enhancement: 
        Bug Fix:     
        Security:
Subscription Information: 
    UUID:            
    Last Checkin:    
    Service Level:   
    Release Version: 
    Autoheal:        
    Registered At:
Host Collections:         
 1) Id:   1
    Name: Test_bug_Dev

Version-Release number of selected component (if applicable):
hammer-cli-katello 0.11.1

Steps to Reproduce:
1. create a host
2. run hammer host info --id <hostid>

Actual results:

No content-source information from "hammer host info --id <host-id>"

Expected results:

Should list content-source information from "hammer host info --id <host-id>"

Additional info:

API provides the data, the fix should be just matter of adding a new field into hammer-cli-katello's extenstions of the host command:
https://github.com/Katello/hammer-cli-katello/blob/master/lib/hammer_cli_katello/host_extensions.rb


Related issues

Is duplicate of Katello - Bug #21057: Missing 'Content Source' output in `hammer host info`Closed2017-09-21

History

#1 Updated by Tomáš Strachota over 4 years ago

  • Subject changed from Unable to view the content-source information from hammer host info to Unable to view the content-source information from hammer host info
  • Category changed from Hosts to Hammer
  • Difficulty set to trivial

#2 Updated by Tomáš Strachota over 4 years ago

  • Description updated (diff)

#3 Updated by Andrew Kofink over 4 years ago

  • Is duplicate of Bug #21057: Missing 'Content Source' output in `hammer host info` added

#4 Updated by Andrew Kofink over 4 years ago

  • Status changed from New to Closed

#5 Updated by John Mitsch over 4 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF