Project

General

Profile

Bug #21194

Incorrect Next Sync date calculation in weekly Sync Plan

Added by Walden Raines almost 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1396647
++ This bug was initially created as a clone of Bug #1302098 ++

Description of problem:

Setting the Start Date for some weekly Sync Plan schedules results in an incorrect date calculation that causes the Next Sync date to skip a week.

Issue appears to be linked at at one specific date.

Version-Release number of selected component (if applicable):

Satellite 6.1.5 at least

How reproducible: Appears to be every time

Steps to Reproduce:
1. Create weekly Sync Plan
2. Set Start Date to Jan 22, 2016 (may be date specific)
3. Next Sync date should show Feb 5, 2016 (skipping Jan 29, 2016)

Actual results:

Next Sync date reports Feb 5, 2016

Expected results:

Next Sync should be Jan 29, 2016

Additional info:

Customer reported this in their environment and it was also reproduced in house with the start date Jan 22, 2016. Using the start date Jan 25, 2016 /did not/ reproduce the error.

--- Additional comment from on 20160202T21:29:30

I heard from the on site DEE that while the Next Sync date displayed Feb 5, the since actually execute and run on Jan 29 as would normally be expected.

In other words, the logic seems to work (e.g., every Friday), just the display of the next date the sync will run was in error (e.g., the following Friday).

--- Additional comment from on 20160212T14:16:28

Bryan, thank you for flipping this to the correct component. Does anything need to happen to flip this to assignee/bin too?

--- Additional comment from on 20160212T14:19:19

Matt, no worries, we will take care of assigning it.

--- Additional comment from on 20160419T13:35:19

Could I get a status update on this issue for my customer? Any chance this might get addressed some time in 6.2?

--- Additional comment from on 20160513T17:55:45

moved to zStream based on conversations with GSS, PM, QA, and ENG

--- Additional comment from on 20160531T16:51:41

Removing old target milestone based on move to zStream.

--- Additional comment from on 20160531T16:56:07

Removing old target milestone based on move to zStream.

--- Additional comment from on 20160809T13:55:41

Do we have a sense if this will make it into the upcoming zstream for later this month or still TBD? Thanks.

--- Additional comment from on 20160809T17:35:49

(In reply to Matt Ruzicka from comment #8)

Do we have a sense if this will make it into the upcoming zstream for later
this month or still TBD? Thanks.

I plan on doing my best to get as many of my zstream bugs done in priority order as possible.

--- Additional comment from on 20160809T18:41:40

Created redmine issue http://projects.theforeman.org/issues/16035 from this bug

--- Additional comment from on 20160809T19:14:34

PR: https://github.com/Katello/katello/pull/6238

--- Additional comment from on 20160809T20:12:21

Upstream bug component is Content Management

--- Additional comment from on 20160822T18:12:18

Moving to POST since upstream bug http://projects.theforeman.org/issues/16035 has been closed

--- Additional comment from on 20160822T18:38:09

Thanks for the update Bryan. Would we expect to see this in 6.2.2 or will we need to wait for 6.3 since it landed in the current foreman?

--- Additional comment from on 20160822T19:06:10

Matt, this is slated for 6.2.z. Given the number of customer cases it may not make it into the first two. Regardless of the inclusion in 6.2.z, it will be available in 6.3.

-- bk

--- Additional comment from on 20161003T16:30:09

I am moving all bugs which have been addressed in either katello 3.2 or foreman 13.0 and 13.1 to ON_QA. These bugs have been delivered in the first 3 snaps.

--- Additional comment from on 20161003T16:54:04

Moving all bugs which are fixed in Katello 3.2 to ON_QA for 6.3. These were delivered in the initial snaps of 6.3.

--- Additional comment from on 20161021T09:29:47

Verified in Sat 6 snap 5. Next sync is calculated correctly for weekly sync in case the start date is less than a week in past from the current day.

Associated revisions

Revision 89fcecb8 (diff)
Added by Walden Raines almost 4 years ago

Fixes #21194: fix next sync calculation for weekly sync plan.

The sync plan next sync calculation was incorrect for dates exactly
a week prior plus some time after the current time. In this case we
should have next sync be the current date plus the time ahead of now.

http://projects.theforeman.org/issues/21194

History

#1 Updated by The Foreman Bot almost 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6990 added

#2 Updated by Walden Raines almost 4 years ago

  • Target version set to 218

#3 Updated by Walden Raines almost 4 years ago

  • Target version changed from 218 to 224

#4 Updated by Walden Raines almost 4 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

#5 Updated by Eric Helms almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 284

Also available in: Atom PDF