Project

General

Profile

Bug #21201

Notification link not properly shown

Added by Walden Raines 12 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1488975
Description of problem:

Notifications on UI Drawer don't have enough space to be properly show on screen (see screen shot). To access Detail link one have to scroll inside the html element.

Version-Release number of selected component (if applicable):

6.3 snap 14

How reproducible:

Always

Steps to Reproduce:
1. Make a discovery host available
2. Open Notification Drawer
3. Click on notification's detail (The 3 dots icon on top right corner)

Actual results:

Detail button is hidden and user must scroll to access it.

Expected results:

Button should be accessible without scrolling.
Additional info:


Related issues

Related to Foreman - Refactor #23357: Migrate notification-drawer to use patternfly-reactClosed2018-04-22

History

#1 Updated by Walden Raines 12 months ago

  • Target version set to 224

#2 Updated by Walden Raines 12 months ago

  • Assignee set to Amir Fefer

#3 Updated by Amir Fefer 11 months ago

Looks like this bug has been resolved, as you can see at the uploaded screenshot.

#4 Updated by Ohad Levy 11 months ago

Amir Fefer wrote:

Looks like this bug has been resolved, as you can see at the uploaded screenshot.

Amir - also you screenshot looks wrong, the dropdown should be just below the kebab. I wonder if we are misusing the pf css in this case as these are the kind of bugs that I don't believe exists in pf repos.

#5 Updated by Walden Raines 11 months ago

  • Target version changed from 224 to 228

#6 Updated by Walden Raines 10 months ago

  • Target version changed from 228 to 234

#7 Updated by Walden Raines 9 months ago

  • Target version changed from 234 to 237

#8 Updated by Walden Raines 9 months ago

  • Target version changed from 237 to 239

#9 Updated by Walden Raines 8 months ago

  • Target version changed from 239 to 243

#10 Updated by Walden Raines 7 months ago

  • Target version changed from 243 to 248

#11 Updated by Walden Raines 7 months ago

  • Target version changed from 248 to 250

#12 Updated by Walden Raines 6 months ago

  • Target version changed from 250 to 253

#13 Updated by Walden Raines 3 months ago

  • Target version deleted (253)

#14 Updated by Amir Fefer 3 months ago

Looks like migrating to patternfly-react fixed this issue
https://projects.theforeman.org/issues/23357
see attached image.

#15 Updated by Amir Fefer 3 months ago

  • Related to Refactor #23357: Migrate notification-drawer to use patternfly-react added

#16 Updated by Amir Fefer 3 months ago

  • Status changed from New to Duplicate

Also available in: Atom PDF