Project

General

Profile

Bug #21271

Irrelevant Errata count in Bulk Actions

Added by Brad Buckingham over 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Web UI
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1317696

Description of problem:
Bulk action shows irrelevant Errata for the selected content hosts. Some erratas gets displayed as 0 'Affected Content Hosts'.
Also, there is no way to sort the affected content hosts to put the relevant erratas on top.

How reproducible:
Always

Steps to Reproduce:
1.Go to satellite Hosts -> Content Hosts -> Select few hosts -> Click on 'Bulk Actions' -> Click on 'Errata '
2.It will display all the errata available from the repositories.(eg : Showing 20 of 634 (72736 Total))
3.Also, it will display some erratas with 0 affected hosts.

Actual results:
- All available erratas are displayed .
- List displays few erratas with 0 affected hosts.
- can't sort by Affected Content Hosts to put the relevant ones at the top.
- *can't select all of the hundreds of errata without scrolling down because it only loads 20 at a time.

Expected results:
- it should display correct errata count
- There should be a way to sort the content hosts which are affected.
- There should be a way to select all erratas without scrolling.


Related issues

Related to Katello - Bug #21283: Listing errata for host groups does not work unless host and content facet have the same idClosed2017-10-10

History

#1 Updated by Brad Buckingham over 4 years ago

  • Subject changed from Irrelevant Errata count in Bulk Actions of satellite 6.1.x to Irrelevant Errata count in Bulk Actions of satellite 6.1.x
  • Target version set to 225

#2 Updated by Justin Sherrill over 4 years ago

  • Subject changed from Irrelevant Errata count in Bulk Actions of satellite 6.1.x to Irrelevant Errata count in Bulk Actions

#3 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) set to 250

#4 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) deleted (250)
  • Status changed from New to Assigned

#5 Updated by Justin Sherrill over 4 years ago

  • Status changed from Assigned to Duplicate

#6 Updated by Justin Sherrill over 4 years ago

  • Related to Bug #21283: Listing errata for host groups does not work unless host and content facet have the same id added

#7 Updated by Eric Helms over 4 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF