Project

General

Profile

Feature #21287

Add resource switcher to foreman

Added by Walden Raines 12 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

We added something like this in katello and it allows the user to switch between items of the same type when they are on a "details" page for an item.

UX is now requesting that we add the same to foreman.

History

#1 Updated by Marek Hulán 11 months ago

  • Category set to Web Interface

#2 Updated by Walden Raines 11 months ago

  • Assignee set to Avi Sharvit

#3 Updated by Marek Hulán 11 months ago

Does this go to smart proxy and host detail page only or does that imply replacing of two-pane?

#4 Updated by Walden Raines 11 months ago

Marek Hulán wrote:

Does this go to smart proxy and host detail page only or does that imply replacing of two-pane?

Sorry, I need to update this with more information.

This feature involves removing two pane everywhere it exists in foreman and replacing it with breadcrumbs and the switcher.

#5 Updated by Marek Hulán 11 months ago

I might be late on mail/demos but was this discussed with the community? For the record, I'm not against, I'd just like to avoid surprises.

#6 Updated by Walden Raines 11 months ago

  • Target version changed from 224 to 228

#7 Updated by Walden Raines 10 months ago

  • Target version changed from 228 to 234

#8 Updated by Walden Raines 9 months ago

  • Target version changed from 234 to 237

#9 Updated by Walden Raines 9 months ago

  • Target version changed from 237 to 239

#10 Updated by Walden Raines 9 months ago

  • Assignee changed from Avi Sharvit to Amir Fefer

#11 Updated by The Foreman Bot 8 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5188 added

#12 Updated by Walden Raines 8 months ago

  • Target version changed from 239 to 243

#13 Updated by Walden Raines 7 months ago

  • Target version changed from 243 to 248

#14 Updated by Walden Raines 7 months ago

  • Target version changed from 248 to 250

#15 Updated by Walden Raines 6 months ago

  • Target version changed from 250 to 253

#16 Updated by Walden Raines 5 months ago

  • Status changed from Ready For Testing to Duplicate

Duplicate of #22855

#17 Updated by Walden Raines 3 months ago

  • Target version deleted (253)

Also available in: Atom PDF