Project

General

Profile

Bug #21288

Could not able to upload packages to yum repository.

Added by Andrew Kofink about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1487903

Description of problem: we were trying to upload packages to yum repository.When attempted to upload any invalid file to yum repo, it throws error as "Error during upload : Task :Katello:Errors::PulpError:The importer indicated failed response when uploading" and production.log shows 500 internal server error.
And later tried to upload any valid rpm packages it shows "Error during upload:Required lock is already taken by other running task" and production.log again shows 500 internal server error. we could not able to delete that repo also.

Version-Release number of selected component (if applicable): satellite 6.3 snap 14

*How reproducible:*always

Steps to Reproduce:
1. Create a product
2. Create a repository
3. Try to upload any invalid file(text file,image)
4. It shows error which is valid but production.log shows 500ISE.
tail -f /var/log/foreman/production.log
5. Try to upload any valid rpm package.
6. Try to delete repo/product.

Actual results: While uploading invalid file, 500 internal server error in production.log and notification shows "Error during upload : Task :Katello:Errors::PulpError:The importer indicated failed response when uploading".After that user could not able to upload valid rpm packages due to "Required lock is already taken by other running tasks."

Expected results: While uploading invalid file, it should display valid message and log error should be get handled. After that, user should be able to upload valid rpm packages and can also delete repo/product.

Additional info:

Associated revisions

Revision 19829e08 (diff)
Added by Andrew Kofink about 3 years ago

Fixes #21288: Skip failed pulp importer on upload

History

#1 Updated by Andrew Kofink about 3 years ago

  • Subject changed from Could not able to upload packages to yum repository. to Could not able to upload packages to yum repository.
  • Assignee set to Andrew Kofink

#2 Updated by Justin Sherrill about 3 years ago

  • Legacy Backlogs Release (now unused) set to 250

#3 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7012 added

#4 Updated by Andrew Kofink about 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF