Project

General

Profile

Feature #2132

Allow overriding of class parameters in the hostgroup UI

Added by David Schmitt over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When managing parameterized classes, parameters can be overridden by-host, directly from the host's page. The same would be very useful to have on the hostgroup page: the ability to add per-hostgroup overrides/defaults for class parameters.


Related issues

Related to Foreman - Feature #2220: Matchers should support inheritance of smart class parameters in nested hostgroupsClosed2013-02-19
Has duplicate Foreman - Feature #2150: Set params-value in hostgroupDuplicate2013-01-21
Has duplicate Foreman - Feature #2057: Allow Param Class overrides in HostgroupsDuplicate2012-12-18

Associated revisions

Revision 7acc469b (diff)
Added by Amos Benari over 6 years ago

fixes #2132 Smart Variables in hostgroup. 1. Show smart variables in hostgroup view. 2. Added the GUI to override smart variables values in host group.

Revision f591528c (diff)
Added by Amos Benari over 6 years ago

refs #2132 - fixes ajax on puppetclass update, and some typos.

History

#1 Updated by Dominic Cleal over 6 years ago

  • Category set to Web Interface

#2 Updated by David Schmitt over 6 years ago

This seems to be a duplicate of #2057?

Note to self: hostgroup matcher syntax: "hostgroup=Parent Hostgroup/Nested Hostgroup". no quotes!

#3 Updated by David Schmitt over 6 years ago

Hmm, one of the pain points I've got with the hostgroup= matcher, is that this only matches on equality, but other usages of hostgroups exept this inherit.

#4 Updated by Dominic Cleal over 6 years ago

  • Target version set to 1.2.0

#5 Updated by Ohad Levy over 6 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Amos Benari

#6 Updated by Amos Benari over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF