Project

General

Profile

Bug #21321

Can't upgrade Puppet 3 to Puppet 4 on Capsule

Added by Eric Helms almost 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1500818

Description of problem:
Running
  1. satellite-installer --scenario capsule --upgrade-puppet
    or
  2. satellite-installer --upgrade-puppet
    on Capsule leads to error: "Puppet 3 to 4 upgrade is not currently supported for the chosen scenario."

Version:
Tried with Sat6.3 snap 19.

How reproducible:
Deterministic

Steps to Reproduce:
1. On a Capsule, run # satellite-installer --scenario capsule --upgrade-puppet

Actual results:
Error

Expected results:
Upgrade from Puppet 3 to 4 should work

Associated revisions

Revision 3fa59d32 (diff)
Added by Eric Helms almost 4 years ago

Fixes #21321 - Check for foreman_proxy_content to allow puppet upgrade

History

#1 Updated by The Foreman Bot almost 4 years ago

  • Assignee set to Eric Helms
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/551 added

#2 Updated by Eric Helms almost 4 years ago

  • Status changed from Ready For Testing to Closed

#3 Updated by Eric Helms almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 250

Also available in: Atom PDF