Project

General

Profile

Bug #21336

Upgrade to katello 3.5 give a error with puppet agent

Added by Mario Gamboa over 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Error: Package: 1:foreman-installer-1.16.0-0.1.RC1.el7.noarch (foreman)
Requires: puppet-agent >= 1.6.1 **************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf

Error: Package: 1:foreman-installer-1.16.0-0.1.RC1.el7.noarch (foreman)
Requires: puppet-agent >= 1.6.1
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

History

#1 Updated by Mario Gamboa over 4 years ago

  • Status changed from New to Resolved

Just upgrade puppet on fly with foreman-installer --upgrade-puppet

Also available in: Atom PDF