Project

General

Profile

Bug #21338

Upgrade to katello 3.5 RC1 got error in the Upgrade Step: correct_puppet_environments (this may take a while) ...

Added by Mario Gamboa almost 2 years ago. Updated about 1 year ago.

Status:
Feedback
Priority:
Normal
Assignee:
-
Category:
Puppet
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

INFO 2017-10-16 12:22:07 main] Upgrade Step: correct_puppet_environments (this may take a while) ...
[DEBUG 2017-10-16 12:22:11 main] /usr/share/foreman/lib/foreman.rb:8: warning: already initialized constant Foreman::UUID_REGEXP
[DEBUG 2017-10-16 12:22:11 main] /usr/share/foreman/lib/foreman.rb:8: warning: previous definition of UUID_REGEXP was here
[DEBUG 2017-10-16 12:22:22 main] rake aborted!
[DEBUG 2017-10-16 12:22:22 main] Not all the services have been started. Check the status report above and try again.
[DEBUG 2017-10-16 12:22:22 main] /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.5.0.rc1/lib/katello/tasks/reimport.rake:10:in `block (2 levels) in <top (required)>'
[DEBUG 2017-10-16 12:22:22 main] Tasks: TOP => katello:correct_puppet_environments => katello:check_ping
[DEBUG 2017-10-16 12:22:22 main] (See full trace by running task with --trace)
[DEBUG 2017-10-16 12:22:22 main] {:services=>
[DEBUG 2017-10-16 12:22:22 main] {:pulp=>{:status=>"ok", :duration_ms=>"37"},
[DEBUG 2017-10-16 12:22:22 main] :pulp_auth=>{:status=>"ok", :duration_ms=>"25"},
[DEBUG 2017-10-16 12:22:22 main] :candlepin=>{:status=>"ok", :duration_ms=>"16"},
[DEBUG 2017-10-16 12:22:22 main] :candlepin_auth=>{:status=>"ok", :duration_ms=>"25"},
[DEBUG 2017-10-16 12:22:22 main] :foreman_tasks=>
[DEBUG 2017-10-16 12:22:22 main] {:status=>"FAIL",
[DEBUG 2017-10-16 12:22:22 main] :message=>
[DEBUG 2017-10-16 12:22:22 main] "some executors are not responding, check /foreman_tasks/dynflow/status"}},
[DEBUG 2017-10-16 12:22:22 main] :status=>"FAIL"}
[ERROR 2017-10-16 12:22:22 main] foreman-rake katello:correct_puppet_environments COMMIT=true failed! Check the output for error!
[ERROR 2017-10-16 12:22:22 main] Upgrade step correct_puppet_environments failed. Check logs for more information.
[DEBUG 2017-10-16 12:22:22 main] Exit with status code: 1 (signal was 1)
[DEBUG 2017-10-16 12:22:22 main] Cleaning /tmp/kafo_puppet20171016-21224-bzrj1p.conf
[DEBUG 2017-10-16 12:22:22 main] Cleaning /tmp/kafo_hiera20171016-21224-4h8gs0
[DEBUG 2017-10-16 12:22:22 main] Cleaning /tmp/kafo_puppet20171016-21224-w93xmd.conf
[DEBUG 2017-10-16 12:22:22 main] Cleaning /tmp/default_values.yaml
[ INFO 2017-10-16 12:22:22 main] Installer finished in 327.761611552 seconds
~

History

#1 Updated by Justin Sherrill over 1 year ago

Can you re-test when the RC2 is available?

#2 Updated by Mario Gamboa over 1 year ago

yes sure when rc2 is available i will try again update

#3 Updated by Eric Helms over 1 year ago

  • Status changed from New to Feedback

#4 Updated by Mario Gamboa over 1 year ago

Mario Gamboa wrote:

yes sure when rc2 is available i will try again update

sorry eric i just forgot to explain this error is happen when try to upgrade from 3.4.5 to 3.5 rc1 with foreman-installer upgrade method is one of the last step to finish the procedure of upgrade but is crash and i don't know if this affect the final result of the upgrade

#5 Updated by Andrew Kofink over 1 year ago

  • Legacy Backlogs Release (now unused) changed from 250 to 114

Also available in: Atom PDF