Project

General

Profile

Bug #21406

Remove to_proc syntax from Katello Kickstart Default

Added by Lukas Zapletal over 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Provisioning
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I have just installed latest 3.4 and this patch is missing from Default Kickstart Template: https://github.com/theforeman/community-templates/pull/411/files

RHEL installation errors out with:

Safemode doesn't allow to access 'block_pass' on &:present?

https://gist.github.com/lzap/df6c103573dba61cc5bc22d39c6201b6

We need to have the change in Katello templates as well I believe.

It's been fixed in all templates but few of them are still affected:

> ProvisioningTemplate.where("template LIKE '%&:present%'").pluck(:name)
=> ["Katello Atomic Kickstart Default", "Katello Kickstart Default"]

Related issues

Is duplicate of Katello - Bug #20836: Safe mode rendering does not correctly prevent using symbol to proc callsClosed2017-07-11

History

#1 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) set to 166
  • Status changed from New to Duplicate

#2 Updated by Justin Sherrill over 4 years ago

  • Is duplicate of Bug #20836: Safe mode rendering does not correctly prevent using symbol to proc calls added

Also available in: Atom PDF