Project

General

Profile

Bug #21435

hammer host-collection list requires organization parameter with host-id provided

Added by Andrew Kofink over 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Host Collections
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1503704

Description of problem:

[root@cisco-b420m3-01 ~]# hammer host-collection list --host-id 2
Error: Could not find organization, please set one of options --organization, --organization-label, --organization-id.
[root@cisco-b420m3-01 ~]# hammer host-collection list --host-id 3 --organization-id 1
Couldn't find Host::Managed with 'id'=3 [WHERE "hosts"."type" IN ('Host::Managed')]

This should not happen, since host-id is unique, so satellite should be able to figure out the appt organization.
Also, this is a regression since last snap (6.3.0-19)

Version-Release number of selected component (if applicable):
6.3.0-20

How reproducible:

Steps to Reproduce:
1. create a host collection and create & add a host into it
2. try to list host collection by specifying its member id (host-id)

Actual results:
organization parameter required

Expected results:
should be able to list the HC

Additional info:


Related issues

Related to Katello - Bug #20574: API call of GET /katello/api/host_collections says organization_id optional, but doesn't accept without organization idClosed2017-08-13
Related to Katello - Bug #22503: hammer host-collection list doesn't require organization optionsClosed2018-02-02

Associated revisions

Revision 91198847 (diff)
Added by Andrew Kofink over 4 years ago

Fixes #21435 - org_id not required in HCs#index

organization_id is not required in host_collections#index

History

#1 Updated by The Foreman Bot over 4 years ago

  • Assignee set to Andrew Kofink
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7024 added

#2 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) set to 295
  • Category set to Host Collections
  • Subject changed from hammer host-collection list requires organization parameter with host-id provided to hammer host-collection list requires organization parameter with host-id provided

#3 Updated by Andrew Kofink over 4 years ago

  • Related to Bug #20574: API call of GET /katello/api/host_collections says organization_id optional, but doesn't accept without organization id added

#4 Updated by Andrew Kofink over 4 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

#5 Updated by Andrew Kofink over 4 years ago

  • Related to Bug #22503: hammer host-collection list doesn't require organization options added

Also available in: Atom PDF