Project

General

Profile

Bug #21480

Disable turbolinks reloading on back button navigation

Added by Walden Raines over 2 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When a user hits the back button turbo links reloads the page which often causes problems with javascript single page applications.

Steps to Reproduce

  1. Go to a page in a SPA
  2. Repeat step 1 by following a link in the SPA
  3. Click the back button
  4. Note turbo links reloads and associated problems (sometimes JS errors, sometimes other problems)

Related issues

Is duplicate of Foreman - Bug #21846: Notification drawer close on click outside is not working wellClosed2017-12-03

History

#2 Updated by Justin Sherrill over 2 years ago

  • Legacy Backlogs Release (now unused) set to 250

#3 Updated by Eric Helms over 2 years ago

  • Legacy Backlogs Release (now unused) changed from 250 to 284

#4 Updated by Walden Raines over 2 years ago

  • Target version changed from 228 to 234

#5 Updated by Walden Raines over 2 years ago

  • Target version changed from 234 to 237

#6 Updated by Walden Raines over 2 years ago

  • Target version changed from 237 to 239

#7 Updated by Walden Raines over 2 years ago

  • Status changed from New to Duplicate
  • Category set to Web UI

This seems to have been resolved when #21846 was resolved so marking as a duplicate.

#8 Updated by Walden Raines over 2 years ago

  • Is duplicate of Bug #21846: Notification drawer close on click outside is not working well added

#9 Updated by John Mitsch over 2 years ago

  • Legacy Backlogs Release (now unused) changed from 284 to 352

Also available in: Atom PDF