Project

General

Profile

Bug #21506

After upgrade to sat 6.3, running 'foreman-maintain upgrade run' gives error

Added by Kavita Gaikwad about 1 year ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

There was satellite server which upgraded to sat 6.3 using foreman-maintain.
foreman maintain version: rubygem-foreman_maintain-0.0.10-1.el7sat.noarch

If you run command again -

foreman-maintain upgrade run

Output:
Could not find scenario satellite_6_3_pre_upgrade_check, found 0 scenarios

Associated revisions

Revision d915add0 (diff)
Added by Kavita Gaikwad about 1 year ago

Fixes #21506 - scenario error on upgrade run

History

#1 Updated by Kavita Gaikwad about 1 year ago

Kavita Gaikwad wrote:

There is a satellite server which was upgraded to sat 6.3 using foreman-maintain.
foreman maintain version: rubygem-foreman_maintain-0.0.10-1.el7sat.noarch

If you run command again -

foreman-maintain upgrade run

Output:
Could not find scenario satellite_6_3_pre_upgrade_check, found 0 scenarios

After checking logs found that installer command failed with kafo error in /var/log/foreman-installer/satellite.log.

#2 Updated by Kavita Gaikwad about 1 year ago

  • Target version set to 230
  • Assignee set to Kavita Gaikwad

#3 Updated by Kavita Gaikwad about 1 year ago

  • Bugzilla link set to 1508353

#4 Updated by The Foreman Bot about 1 year ago

  • Pull request https://github.com/theforeman/foreman_maintain/pull/122 added

#5 Updated by Ivan Necas about 1 year ago

  • Status changed from New to Closed

#6 Updated by Ivan Necas about 1 year ago

  • Legacy Backlogs Release (now unused) set to 327

Also available in: Atom PDF